Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Rosso Maltese - 2009-08-18
Last edited by Thomas Martitz - 2009-08-24

FS#10543 - Tag %wd hide status bar also in browser

Selecting a theme that hides the status bar using the tag %wd, the status bar is also hide in browser screen.
This happens also at boot, when the initial configuration is loaded.

Referred to r22406.

Closed by  Thomas Martitz
2009-08-24 16:14
Reason for closing:  Not a Bug
Additional comments about closing:  

The initial report wasn't a bug, however the problem noticed later in this task was fixed in r22499.

Thomas Martitz commented on 2009-08-21 01:52

I can’t reproduce that. What theme did you use? May it happened that you accidentally turned the statusbar off?

Ah wait, I guess I know what happened. Recently the statusbar setting changed. “statusbar: on” is ignored (and default to off), as the values are “off,top,bottom” now. Update your theme according to that and report back.

Nils Wallménius commented on 2009-08-21 08:37

somewhat related, the themes WPSLIST file still has two entries using “statusbar: on” IIUC this is incorrect?

Rosso Maltese commented on 2009-08-21 10:08

OK, I’m sorry, the theme config file still used “status bar: on”. Changing to a legal value, all becomes right.
You can close the task as “Not a bug”.

Hint: when a configuration’s accepted values change, making obsolete some of them, sometimes is better that the default value is different from “off” or equivalent. I.e., in this case, reading the old value “on”, could be used “top” or the first non-off value.

Thomas Martitz commented on 2009-08-21 11:00

nls, r21825 should’ve fixed that, but JdGordon apparently forget a few themes.

Rosso Maltese commented on 2009-08-21 12:36

I’m sorry, I forgot to mention that I’m using a modified version of Cabbie 3.0.

Nils Wallménius commented on 2009-08-22 08:23

Actually the default values for statusbar and remote_statusbar in settings_list.c is STATUSBAR_TOP so there is some kind of bug here anyway.

Thomas Martitz commented on 2009-08-22 11:41

If a theme was loaded that has statusbar: off (which is still valid), then no theme that’s loaded after can override that with an invalid statusbar line no matter of the default value.

Rosso Maltese commented on 2009-08-22 19:35

According to me, in this case the fall-back value should be a known state (Nils states that’s STATUSBAR_TOP) and not the previous legal value.

Nils Wallménius commented on 2009-08-24 14:50

if that’s the intended behaviour, it doesn’t work.
if i load a theme with “statusbar: top” (cabbiev2 for example) the statusbar is shown as expected.
if i then load a theme with “statusbar: on” (rockbox_default for example) the statusbar goes away.
So it does not retain the previous valid value nor does it fall back to the default value for the setting, but chooses a new value.
Maybe this has something to do with STATUSBAR_OFF being the first enum, and having the value 0?

Thomas Martitz commented on 2009-08-24 14:58

Indeed, that seems like a bug to me.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing