Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Ubuntuxer - 2009-09-14
Last edited by fg - 2009-12-17

FS#10606 - PNG Viewer Error Message: "Out of Memory"

I get the error message “Out of Memory”, if I try to open a big png image. It seems that on the e200 it’s possible to open bigger images than on the Fuze.
In contrast to the Fuze I can open on the e200 an image with the size of 1024×768. On both players I can’t open images with the size of 4096×1024.
The error message occurs also in the simulator.

r22699

Closed by  fg
2009-12-17 23:11
Reason for closing:  Not a Bug
Admin
fg commented on 2009-09-14 16:46

Why is this a bug?

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

I suppose it’s a memory leak, because the author of the png viewer wrote that he have done benchmarks with images with a size of 1536×2048 and 1680×1050.
http://www.rockbox.org/tracker/task/9493#comment31637

Admin
fg commented on 2009-09-14 18:03

Did you try those sizes on e200?

The e200v1 (which bechris mentions using) has 4x the memory of the Fuze (32MB vs. 8MB). It should be able to do much, much larger images then the fuze. Probably by a factor of 6+ when the difference in audiobuffer is taken into consideration.

The fuze actually has trouble with a few plugins just because it has so little memory for a SWCODEC color screen target.

Ok, I noticed itsn’t really a bug. Wether the player is able to open an image depends on the size of the image. It seems, that the e200 has got a little bit more memory as the Fuze. Or Perhaps the e200 use the memory more effective.
But on the Fuze I get another error message, which says: “other error long number”, which I don’t get on any other player.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing