Rockbox

Tasklist

FS#10663 - Prefetch abort on Sansa AMS e200V2 r23020 5920646C / 5800656C 5 seconds after startup

Attached to Project: Rockbox
Opened by Thomas Lloyd (thomaslloyd) - Friday, 09 October 2009, 00:41 GMT
Last edited by Rafaël Carré (funman) - Thursday, 15 October 2009, 07:17 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r23020 of svn breaks rockbox on my Sansa e200v2. I now get prefetch failed after about 5 seconds after startup and this continiues to loop. Start erro restart:

The error given sometimes is

Prefetch Aboirt
at 5920646C

and 5800656C

I have not had chance to go back revisions to see when the bug was introduced yet.
This task depends upon

Closed by  Rafaël Carré (funman)
Thursday, 15 October 2009, 07:17 GMT
Reason for closing:  Not a Bug
Comment by Thomas Lloyd (thomaslloyd) - Friday, 09 October 2009, 12:59 GMT
Oh and if i spin the sscroll where i get a

Data Abort
at 30047EC0
Comment by Thomas Lloyd (thomaslloyd) - Friday, 09 October 2009, 13:36 GMT
A full format, build veryclean has seemed to solve the problem but i will continue to try and get the problem back.
Comment by Bertrik Sikken (bertrik) - Saturday, 10 October 2009, 10:50 GMT
The prefetch abort address looks like it's composed of printable characters: 0x5920646C = "Y dl" and 0x5800656C = "X\0el"
Comment by Rafaël Carré (funman) - Thursday, 15 October 2009, 05:20 GMT
if build veryclean fixes the problem then it's probably related to unsynced .o files
Comment by Thomas Lloyd (thomaslloyd) - Thursday, 15 October 2009, 07:06 GMT
i removed the whole lot and as you said did make veryclean build and it seems to be behaving again. Can someone with the correct level of access close this.

Loading...