• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mc2739 - 2009-10-19
Last edited by mc2739 - 2011-07-26

FS#10691 - Rbutil will not autodetect e200v2 in win7

Rbutil v1.2.3 will not autodetect e200v2 in win7.

It will autodetect e200v2 in winxp.

It will autodetect e200v1 in win7.

Closed by  mc2739
2011-07-26 23:33
Reason for closing:  Out of Date
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

works in latest release of RockboxUtility (v1.2.10)

Can you give us a Log file from this problem ?

Ie. try Autodetect on win7 and afterwards go to About→Troubleshoot→System Trace and save the log. Then post it here.

Here is the system trace log.

This is what I did:
1. I verified the e200v2 was in MSC mode.
2. I start rbutil - it has e200v1 selected (from a previous run).
3. I click the change button. The Configuration window opens with the Sandisk branch expanded and the e200v1 selected.
4. I click the Autodetect button and the Sandisk branch collapses. All other branches are also collapsed.
5. I click OK and get a configuration error message “No player selected”.

I ran rbutil normally and as administrator and attached both log files.

This looks really strange.
The logs show, that the autodetection found a e200v2 on E:/ via the rockbox-info.txt file in both runs. I really wonder why it doesnt select the e200v2 on win7.

This looks pretty much like a BuildNames mess issue to me: autodetection finds an “e200v2” via rockbox-info.txt, but the string used for identifying the player internally is “sansae200v2” instead. The same issue should appear for the e200, but for that detection usually works using sansapatcher.

Here is the log from my winxp system where it did autodetect. It detected on the USB string. Both the win7 log and the winxp log appear to have the same string, but in the winxp log, there are 2 identical strings together. In the win7 log they are not together.

Edit: I just tried my e200v1 on win7 again, it did not autodetect, although I sure thought it did previously. I am attaching the log from this also.

Yes, this is a problem with the naming mess.
All Logs show that it detects via rockbox-info.txt, but the names from rockbox-info.txt are not what rbutil expects.

What is strange, is that the rbutil-xp.log shows a “sansae200v2” from rockbox-info.txt, which is what rbutil expects, but the current build does contain the “e200v2” string ?

I thought in rbutil-xp.log it detected here:
[System] “USBSTOR\DiskSanDisk_Sansa_e260__v03.”
[USB] detected supported player “sansae200v2”

or is this where it was detected?
[RockboxInfo] trying to find rockbox-info at “E:/”
[Autodetect] rockbox-info.txt detected: “sansae200v2” “E:/”

I guess I’m really confused. I thought that the USB VID-PID were used for detection.
In the win 7 log, the VID-PID for the e200v2 is listed: [System] “USB\VID_0781&PID_7423&REV_⇔4”

The current state of the autodetection is problematic at best. What’s happening in your log is quite simple: autodetection runs the USB detection first, then tries other methods. Now if the detection based on rockbox-info.txt succeeds it overwrites the already detected target string, thus the string in rockbox-info.txt is relevant. If that string is wrong (because rockbox-info.txt uses a different string) it will obviously fail. This needs to get fixed in the autodetection functionality.

It’s still rather strange why the Windows 7 setup shows a different string.


Available keyboard shortcuts


Task Details

Task Editing