Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#10696 : connecting iTrip Auto causes switch to original firmware

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Bootloader
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mattbehrens - 2009-10-20
Last edited by fg - 2009-12-17

FS#10696 - connecting iTrip Auto causes switch to original firmware

Player: Sansa Fuze V1
Build: r23283-091019
Bootloader: created by rbutil from Sansa OF 01.02.26

I have one of these guys here for car listening:

http://www.griffintechnology.com/products/itripautosansa/

Problem is that when I connect it, whether the Fuze is powered off or Rockbox is already running, I get booted into the OF as if I had connected a USB cable. The OF, however, does not try to start USB mode, instead booting normally (except it doesn’t, because I have some files that overrun the OF’s tag reading code… but that’s another problem entirely) ;)

When using OF, the iTrip Auto will start the Fuze normally.

The iTrip Auto provides both charging and a line-out connection.

Closed by  fg
2009-12-17 23:20
Reason for closing:  Not a Bug
Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Does this help:

http://download.rockbox.org/daily/manual/rockbox-sansafuze/rockbox-buildch3.html#x5-370003.3

Sort of. (I was actually just coming back to report the results of testing this :) Sorry I missed it before I opened the bug.)

It doesn’t seem to do anything if I’m plugging it into a turned-off Fuze; OF still boots.

It does seem to work (as in, not switch to OF) if Rockbox is already booted, but I’m not getting any sound output. Probably not outputting over line-out, I’m guessing.

I do not think there has been any work done on getting line out working on the Fuze, or any of the other Sansa AMS models. This may be due to lack of docking accessories among the developers. If you would care to dive in to the source, it might help to get accessory support come about sooner.

I think maybe there are two issues here and I should perhaps open another task, with line-out being an enhancement request. (Maybe this is an enhancement request, too?)

#1: Connecting either the iTrip *or* the standard USB cable (just verified this morning) if the Fuze is turned off will boot OF. Holding Select does not boot Rockbox in this case. Select only works if Rockbox is already running. So this seems like either a bootloader bug or enhancement request, I don’t know which?

I would help, but as I’m a Rockbox neophyte, I don’t really feel comfortable diving into the bootloader.

#2: Line-out does not work with accessories. I can open another task for this. I am willing to see what I can do to code this, but I can’t promise I’ll get anywhere or soon as I’m really a low-level kind of guy.

#1 is standard operation for this platform until USB is fully implemented. If you want to use Rockbox with your dock, you must boot into Rockbox first and then press the select button while connecting to your dock. If the dock supplies power when the car is started, then you could power up the player in the dock before starting the car and press select while starting.

#2 You can open another task for this if you plan to work on it and have a patch available for testing. Since line out is an unimplemented feature, please do not open a bug report. If you just want a feature request for line out, the “Feature Ideas” section on the forum would be the proper place to post.

Allright, well, I suppose we can close this out then. I had a look at dualboot.S to see how possible it might be to patch #1 in; it looks possible, but there are a few things I don’t understand about how to scan for other keys—that and I’m generally squeamish about playing with the bootloader, as I mentioned.

Although it is possible to modify the bootloader, it is highly discouraged. A malfunctioning bootloader can brick your Fuze, and the Fuze does not have any known recovery method.

Do any of the GPIO pins in the debug menu change when you plug in the dock? Would be interesting to know if theres a way to detect it separately from an AC adapter.

Not by GPIO, it seems. GPIOA changes from E2 to EA on both the official USB cable and the iTrip.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing