Rockbox

Tasklist

FS#10702 - H300 simulator auto-pauses every few minutes

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Wednesday, 21 October 2009, 15:18 GMT
Last edited by Steve Bavin (pondlife) - Wednesday, 21 October 2009, 16:14 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm running an H300 simulator (r23306) on Windows XP.

Often (generally within 1 to 5 minutes), playback is paused just like the PLAY/PAUSE button (the + key) has been pressed. The fade on pause occurs, and the WPS displays paused status.

Pressing the PLAY/PAUSE button again resumes, so nothing seems to be corrupted, but it then repeats the auto-pause a while later.

I've binary-chopped and it seems that this problem was introduced in r22799 (i.e. r22798 works ok, but r22799 does not).

I'll put some tracing into the SDL button driver, but maybe someone who knows more about this could spot the problem faster.
This task depends upon

Closed by  Steve Bavin (pondlife)
Wednesday, 21 October 2009, 16:14 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  This was caused by having car adaptor mode enabled. The simulated unplugging of the charger was then (correctly) pausing.
The newer button driver fixed event handling, hence the problem only appears with the newer, better, code.

Loading...