Rockbox

Tasklist

FS#10710 - Keymaps differences between e200 and fuze

Attached to Project: Rockbox
Opened by Tomer Shalev (tomers) - Thursday, 22 October 2009, 05:45 GMT
Last edited by Tomer Shalev (tomers) - Thursday, 22 October 2009, 09:42 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To Tom Ross (midgey34)
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have both e200 and Fuze. They have similar keymaps: scrollbar, SELECT button, four directional buttons, and also another button MENU (e200) / HOME (Fuze).


In WPS, there are some differences between the two, and I wonder whether this is a bug, or there is some reason to it (in that case, don't hesitate to close this as 'not a bug').

1)
Fuze: A short press on HOME switches to the Playlist Menu.
E200: Short press on MENU switches to the Main Menu, which is also accessible by a short press on DOWN, as in the Fuze. I think this action should be changed, and a short HOME should send you to the Playlist Menu.

2)
On Fuze, long HOME switches to Main Menu, while on e200 a long press on MENU turns the player off. I guess this is desired, as the menu button on e200 is also the POWER button.

I would like to fix (1), but I want to hear if somebody objects this first.
This task depends upon

Closed by  Tomer Shalev (tomers)
Thursday, 22 October 2009, 09:42 GMT
Reason for closing:  Invalid
Additional comments about closing:  > I thought MENU on the e200 stopped playback in the wpl?
You are right. The current configuration is correct.
Comment by Jonathan Gordon (jdgordon) - Thursday, 22 October 2009, 05:57 GMT
this should go in the dev mailing list...

1) the fuze is the same as the clip here, HOME and MENU are subtley different, I tihnk going to playlist viewer here is silly, I thought MENU on the e200 stopped playback in the wpl?

Loading...