Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iPod Nano 2G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by obzen - 2009-10-23
Last edited by TheSeven - 2010-06-21

FS#10713 - can't mount nano 2g in xp, after r23288

USB mode should be disabled for now i guess. I couldn't mount my pod, after revision 23288. I can mount it by going back to an early build.

What happens is that, after i mount my ipod nano2g, pc recognises it as a storage drive, but only for a few seconds. After that, it freezes for a few seconds, the icon goes away from my computer, and comes back again, as a different storage device. Can't copy files to it, can't see the files inside. It shows "0" capacity in the properties window.

Closed by  TheSeven
2010-06-21 19:42
Reason for closing:  Out of Date
Additional comments about closing:  

Not touched for ages, probably fixed by now.

obzen commented on 2009-10-23 14:36

….which seems to be fixed by the latest build.

obzen commented on 2009-10-23 14:51

*PANIC*

FTL: Tried to put block 0 in o the pool !

Please always mention the exact revision number this happened with, otherwise it's impossible for me to try to track it down to a specific change.
In r23288 there were many known FTL bugs and USB was in fact disabled, so I wonder why you say we should disable it?

First of all, excuse me for my very bad english
I have the same problem connecting a nano 2nd gen in Debian Lenny with revision r23514. When connecting iPod, gtkpod try to open but it freezes without show anything. I have to force quit and then the computer sees no device at all. To manage files in the player I have to reboot with original firmware and use gtkpod.
When this problem occurs, the fdisk -l command shows hard disks, usb drives, but not iPod even if connected. Mounting is imposible. Finally, the USB logo in the screen is impossible to make it dissapear, is necesary reboot by pressing menu and the central key.

obzen commented on 2009-11-08 22:55

Try this. Download the latest build. Install it. Then go the the system settings in rockbox and turn "USB HID" option off. Then try to connect.

OK, tried and it works very well. Thank you very much.

I'm still having this exact problem. I'm using the latest build r23617-091111 and trying to mount in XP.
The drive becomes empty after 10-15 seconds.
I've tried enabling and disabling USB HID and the same thing happens either way.

It works okay if I go from disk mode or from the boot into the apple firmware and then connect.
I just can't transfer or see any files when I connect using Rockbox.

The FTL parts of this problem have probably been fixed by now. The USB issues possibly not.
Please reply if you are still experiencing issues. Frank Gevaerts is currently looking into the USB HID and Mass Storage drivers.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing