• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iPod Nano 2G
  • Severity High
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by obzen - 2009-10-24
Last edited by TheSeven - 2010-02-08

FS#10715 - File transfer interrupts, ending up needing of a "restore"

Latest build. Nano 2G.

Every time i try to transfer files to it, transfer rate is too slow (slower than before), and eventually transfer is interrupted in the middle. When i unplug and reset it, apple says, on a white screen, that ipod needs a restore. I restore it, and it works fine, but when i install rockbox again, during the first file transfer, same thing happens, i reset, and get the restore warning again.

So it is basicly a vicious cycle.

Closed by  TheSeven
2010-02-08 18:40
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This could be either a USB, a NAND- or a FTL-related issue. If it was one of the latter, it's probably fixed by now. I'm closing this as I didn't get any further reports of that issue for quite some time. If it still happens for you, please re-open.

Which one is that "latest build"? Newer than r23308?

obzen commented on 2009-10-24 20:20

"OK, i am pasting my forum reply to here, in case you miss one of them."

Hi. Thanks for the response.

First of all, i should say, this happens with the latest build. Actually, since the usb support is implemented, i am having issues. My first problem was, not being able to access to the flash drive when connected. All i could see was a "0" capacity disk. After the "disable usb hid" option is implemented, that problem is gone. But now i have this. I connect it properly, windows sees it, mounts it. No problem. I can see the files inside. But whenever i try to copy files to it, i notice a very slow transfer rate. This rate goes slower and slower, and at some point it stops completely unfinished. I safely unmount, and i see the player reset itself (i think it shouldn't do that). And the apple message is telling me that i need a restore.

I restored like 3 times or more, trying different options selected and unselected, but it happened all the time.

The thing is, my ipod runs fine with the original apple firmware, and older rockbox builds. I am using r23284 right now, which is the latest build before the USB implementations. Having minor gui issues, but it runs fine.

I hope this helps.

obzen commented on 2009-10-24 23:59

I just tried r23338, and it is the same. White screen telling me, i have to restore my ipod.

So this also happens if you only transfer a very small amount of data, e.g. just create an empty directory or something?
But if you change some settings in rockbox, shut it down, and boot again, it's fine and the settings are being retained?

obzen commented on 2009-10-25 11:32

Yes, exactly how you put it. It also happened when i tried to delete the contents of the ipod. All kinds of file operations to the flash drive (copying, deleting) in windows, ends this way. But i can change settings in rockbox. And i can copy / delete stuff in "disk mode". This only happens when i connect while rockbox is on, and do any file operations in the ipod.

obzen commented on 2009-10-26 13:17


Still the same. I just restored my ipod. Using an older build, with no usb support, it works fine.

obzen commented on 2009-10-27 13:17

r23366 : Restoring ipod again.

r23489 might possibly have fixed it, but it could of course be something entirely different

obzen commented on 2009-11-03 01:20

I tried r23489, but it is the same. File transfer stopped, and white screen telling me to restore came up again. I can copy/delete files in disk mode, but whenever rockbox is running, and i connect it to the usb, it is all right, until i start to copy/delete files in the flash drive. Deleting the files also causes the same problem.

I committed another fix for similar issues in r23570, can you please try if that fixes the issues you're experiencing?

obzen commented on 2009-11-08 18:01

OK, i won't jump to a quick conclusion this time, but at least, i was able to make some file operations (copy/delete) in flash drive, while rockbox is on. But there is a catch. File transfer speed is too slow. Here are the transfer rates (using "send to" command in windows, with large amount of files) that i get in different interfaces.

Rockbox USB: 1.500 KB/s max.
Disk mode: 2.500 - 3.000 KB/s
Apple firmware: 4.500 - 5.000 KB/s

I guess rockbox usb driver is still not on its full potential.

It's not the USB driver, it's the FTL.
We're currently writing everything sequentially to keep it simple until we caught all the bugs, while apple writes to the individual flash banks (up to 4) in parallel. So this slowdown is expected.

obzen commented on 2009-11-08 22:50

Thank you very much for your hard work. I can now confirm that i am not experiencing any USB releated problem after i started using r23570.

obzen commented on 2009-11-08 23:59

OK it just came back. It worked well for some time, turned on and off with no problems. But right now, again, i have the white restore screen on my ipod. I am clueless.

obzen commented on 2009-11-09 21:25

I found something interesting. The problem doesn't seem to happen if i don't "safely remove". When i just pull the usb plug, i don't encounter the problem anymore. But whenever i "safely remove" in windows, it goes to the restore window right after the first off/on cycle. Interesting.

Today i've got restore screen on my nano 2g. I used remove safely and I connected ipod only to charge battery(on ubuntu linux). My revision 24150. My usb configuration was. hid off, usb change on.

For everyone who is still experiencing issues: Please test  FS#10775 , this is fixing one of the possible causes I can imagine for the problems above. I also fixed another FTL bug some days ago, so the issues may already have disappeared.
If you are still experiencing problems and  FS#10775  doesn't fix them for you, please reply.


Available keyboard shortcuts


Task Details

Task Editing