FS#10789 - Divide by Zero text_editor

Attached to Project: Rockbox
Opened by Paolo Fisico (Paolo.Fisico) - Monday, 16 November 2009, 01:26 GMT
Last edited by Teruaki Kawashima (teru) - Thursday, 21 January 2010, 01:18 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Rbutil 1.2.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


When opening a .rock file with text_editor in Rockbox Vesion 3.3 on a Sansa e200 series the player crashes. After scrolling to a certain point (you might have to scroll to the end and back up again), the player crashes (you have to hold power for 30 seconds to turn it on) and displays "Divide by zero at 00063A2C (0)". The same code appears every time.
This task depends upon

Closed by  Teruaki Kawashima (teru)
Thursday, 21 January 2010, 01:18 GMT
Reason for closing:  Fixed
Comment by Thomas Martitz (kugel.) - Monday, 16 November 2009, 01:57 GMT
Can you upload the text file? I tried a really long file and it didn't happen.
Comment by Paul Louden (Llorean) - Monday, 16 November 2009, 02:21 GMT
Shouldn't he start with testing on a current build? 3.3 is rather out of date.
Comment by Will Hauck (moonscapex) - Monday, 16 November 2009, 22:59 GMT
Happens on my Current Build e200 too. When I open a long, complex file (a .rock file for example).
Comment by Teruaki Kawashima (teru) - Tuesday, 17 November 2009, 13:21 GMT
small text file also can cause the "Divide by zero" :)
Comment by Paolo Fisico (Paolo.Fisico) - Saturday, 21 November 2009, 01:50 GMT
I was exploriing this bug more, and I discoverd that if you opan an extremely large (I'm assuming) file such as chip8.rock the player never opens the file. Instead it will immediately crash and display the same divide by zero message.
Comment by amaury pouly (pamaury) - Wednesday, 20 January 2010, 22:02 GMT
I also tried lots of files, big, small, empty ones. I also tried your (teru) file but it didn't crash. Does this bug still exists ? Can you provide more explain files ?
Comment by Teruaki Kawashima (teru) - Thursday, 21 January 2010, 01:17 GMT
I think i fixed this before and forgot to close this.