Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by John Hughes - 2009-11-25
Last edited by Frank Gevaerts - 2009-12-18

FS#10808 - USB Device Disconnect Inoperative With W2K, RB 3.4 and Sansa E260

Environment:
Sansa E260
Rockbox V3.4
Windows 2000
Toshiba A55 Notebook

Problem:

When the Sansa is connected to the PC two new drive letters are assigned as expected, but the drives do NOT appear in the unplug or eject hardware utility. In earlier releases the drive letters did appear and the device could be disconnected without issue. As it now stands the Sansa must either be powered off or abruptly disconnected, and either action causes Windows to raise the unplugged device warning dialog.

devcon shows the following node entries:

USBSTOR\DISK&VEN_ROCKBOX&PROD_INTERNAL_STORAGE&REV_0.00\9&296F6FD&0&900000000000000000000000000000000&0

  Name: Rockbox Internal Storage USB Device

DriverNode #0:

  Inf file is c:\winnt\inf\disk.inf
  Inf section is disk_install
  Driver description is Disk drive
  Manufacturer name is (Standard disk drives)
  Provider name is Microsoft
  Driver date is 11/14/1999
  Driver version is 5.0.2183.1
  Driver node rank is 6
  Driver node flags are 00000240

USBSTOR\DISK&VEN_ROCKBOX&PROD_SD_CARD_SLOT&REV_0.00\9&296F6FD&0&900000000000000000000000000000000&1

  Name: Rockbox SD Card Slot USB Device

DriverNode #0:

  Inf file is c:\winnt\inf\disk.inf
  Inf section is disk_install
  Driver description is Disk drive
  Manufacturer name is (Standard disk drives)
  Provider name is Microsoft
  Driver date is 11/14/1999
  Driver version is 5.0.2183.1
  Driver node rank is 6
  Driver node flags are 00000240

USB drivers in system:

USB\HUB_VID_0409&PID_0059\6&12A06DAE&0&4 : Generic USB Hub
USB\HUB_VID_04B4&PID_6560\5&201EC97&0&4 : Generic USB Hub
USB\HUB_VID_05E3&PID_0608\6&12A06DAE&0&3 : Generic USB Hub
USB\HUB_VID_413C&PID_1002\7&26E84050&0&3 : Generic USB Hub
USB\ROOT_HUB\4&3502F4DF&0 : USB Root Hub
USB\ROOT_HUB\4&3AEF0821&0 : USB Root Hub
USB\ROOT_HUB\4&6C0CF5B&0 : USB Root Hub
USB\ROOT_HUB20\4&201FB031&0 : USB 2.0 Root Hub
USB\VID_04FC&PID_0003\7&26E84050&0&4 : USB Human Interface Device
USB\VID_0781&PID_7421\900000000000000000000000000000000 : USB Composite Device
USB\VID_0781&PID_7421&MI_00\8&14FA9292&0&0 : USB Mass Storage Device
USB\VID_0781&PID_7421&MI_01\8&14FA9292&0&1 : USB Human Interface Device
USB\VID_0930&PID_0C06\SATASLIM00000000000 : USB Mass Storage Device
USB\VID_0D8C&PID_000C\7&26E84050&0&1 : USB Composite Device
USB\VID_0D8C&PID_000C&MI_00\8&2247B755&0&0 : USB Audio Device
USB\VID_0D8C&PID_000C&MI_03\8&2247B755&0&3 : USB Human Interface Device
USB\VID_18A5&PID_0214\SATAUSB0013E5 : USB Mass Storage Device
USB\VID_413C&PID_2002\8&1256AA&0&1 : USB Composite Device
USB\VID_413C&PID_2002&MI_00\9&25B7559C&0&0 : USB Human Interface Device
USB\VID_413C&PID_2002&MI_01\9&25B7559C&0&1 : USB Human Interface Device

Closed by  Frank Gevaerts
2009-12-18 18:29
Reason for closing:  Invalid
Additional comments about closing:  

Some old and buggy operating systems can't handle composite devices. That's not a bug in rockbox.

However, to accomodate those, current builds have a setting to disable HID, so it is possible to avoid the issue by using those.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing