Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Manual
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by reszerve - 2009-12-05
Last edited by GodEater - 2009-12-21

FS#10831 - File View>Follow Playlist Mostly Doesn't Work

If the setting File View →Follow Playlist = yes, then when in the WPS pressing select should show the currently playing track selected in the directory it is in.

This is what does happen if the player has just been booted and play resumed. Otherwise behaviour is as if the option is set to “no”.

This is true on todays daily build r23850, 5Dec09, and at least all recent builds prior to this. I noticed the issue some time ago but have only just figured out when it sometimes worked was related to having booted and not selecting a new playlist.

To reproduce:
While playing a track numbered two or higher and Follow Playlist =yes turn off gigabeat. Now turn gigabeat on. Select “Resume Playback” (if set for main menu on boot), WPS appears playing the same track as at turn=off.

Press “select” to show file view. The directory where the track is should be displayed with the playing track selected. This is correct behaviour for Follow Playlist = yes.

Return to the WPS. Press Windows key for the main menu. Select Database and in the database view select a new track with a track number two or higher. The track should appear playing in the WPS.

Press “select” and you will see the directory where the file is, but track 1 selected. From now on pressing select from the WPS shows the last file view, regardless of what track is playing, until you reboot. This is the correct behavious for “Follow Playlist”=no.

Closed by  GodEater
2009-12-21 09:00
Reason for closing:  Fixed
Additional comments about closing:  

Clarified the action of the "Select" key whilst on the WPS screen in the manual.

i think i found an easier way to reproduce it on an e200 and r23872.

just play any track. go to any folder in the database, e.g. artist. hist play, which takes you to the wps. hit select. you are now in the database-folder artist, not in the file browser.

This is not a bug. “Follow Playlist” only works in the filebrowser - not in the database browser (it can’t work there because the same file can appear in multiple locations of the database).

Pressing the SELECT key in the WPS doesn’t necessarily bring you to the filebrowser, but to the last browsing mode (Database/Filebrowser). Once you switch back to the filebrowser and hit SELECT in the WPS then follow playlist will work normally.

the manual says for select “return to the file browser”, so the manual is wrong. if that gets changed, everything works as expected :) except, when you select a track in the databse and hit select, the first track in the list is marked and not the last selected one.

nls commented on 2009-12-09 16:54

Changed category to “Manual” since it’s more of a documentation issue and chaged to “all players” as it’s not player specific.

I’m not comfortable that this is not a bug with the way Follow Playlist is working. What the manual says makes sense. The way the software behaves does not. The proposal seems to me to be saying make the manual describe the incorrect behaviour and that will fix it???

If i remember correctly it has been this way even before the manual was written.
If you don’t like the current behavior and have a better concept, then i would suggest to open a thread in the “Feature Ideas” forum with your proposal.
http://forums.rockbox.org/index.php?board=49.0

What if making me uncomfortable assigning this as a manual error is that it is being done on a “if i remember correctly”. Have we got a way to verify what the correct behaviour is? Does anyone else recall this?

The manual is definitely wrong. Select has always taken you back to the screen you were last browsing your music from - either the Database, or the File browser.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing