Rockbox

Tasklist

FS#1084 - 199 kb boot limit

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 12 March 2003, 17:07 GMT
Last edited by Björn Stenberg (zagor) - Wednesday, 12 March 2003, 17:37 GMT
Task Type Bugs
Category
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

My Archos Jukebox Recorder 10GB (un-modified 2Mb ram)
will not load an ajz file larger than 199 kilo bytes,
therefore once iv added a few of the additional patches
to the code, it will not load unless loaded through rolo.
so at the rate the code is currently growing in size in a
short while it will pass this limit, unless the apps become
external to the ajz file. another solution which im trying
to make is a lite arj file which just acts as rolo, and loads
a specific file. this could be on the root of the hdd, called
ajbrec.ajz then this could load rockbox.ajz, therefore as
the "boot loader" would be beneath the 199 kb size it
would load, then load the rockbox file which would not
have to be under this 199 kb file size.




HuwSy
This task depends upon

Closed by  Björn Stenberg (zagor)
Wednesday, 12 March 2003, 17:37 GMT
Reason for closing:  Invalid
Additional comments about closing:  Logged In: YES
user_id=1157

Version 2.0 will squeeze under this limit - just barely.

In the future we will add a plugin loader to reduce the amount
of code in ram.

(This is not a bug. Please use the list for questions.)
Comment by Björn Stenberg (zagor) - Wednesday, 12 March 2003, 17:37 GMT

Version 2.0 will squeeze under this limit - just barely.

In the future we will add a plugin loader to reduce the amount
of code in ram.

(This is not a bug. Please use the list for questions.)

Loading...