Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Database
  • Assigned To No-one
  • Operating System iPod Nano 2G
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Darkknight512 - 2009-12-12
Last edited by TheSeven - 2010-02-10

FS#10846 - Nano 2G Data corruption

It appears that if I boot into the apple firmware (Diskmode or Regular) the file system gets corrupt and reports as RAW to windows.

This also happened when I ran the battery all the way down doing a batterybenchmark on the Nano2g, when it rebooted and tried to turn on it booted to the battery low symbol and when I pluged it into my computer it was RAW (I also lost my benchmark T.T though i do know it ran down to 0 at exacly 15 hours.)

Closed by  TheSeven
2010-02-10 21:29
Reason for closing:  Fixed
Additional comments about closing:  

Old and probably fixed by now, please re-open if this is still an issue. The reported behavior is to be expected after an unclean shutdown, but should not happen normally.

jch commented on 2009-12-14 03:55

I’ve noticed this too, the Nano 2g will currently fubar the flash whenever it crashes. This has happened to me upon:

  1. crashing on a division by zero;
  2. crashing on an invalid pointer access.

I’ve had the OF crash without breaking the flash, so there’s obviously something wrong with Rockbox.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing