Rockbox

Tasklist

FS#10859 - User Experience and Rockbox- A rethink required?

Attached to Project: Rockbox
Opened by Aditya (adityabhandari) - Thursday, 17 December 2009, 10:36 GMT
Last edited by Paul Louden (Llorean) - Thursday, 17 December 2009, 12:39 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Rockbox is an amazing and powerful achievement. I own an iPod video 5g and for me, rockbox was a godsend that allowed me to break free from itunes and its tyrannies.

As much as I love rockbox, I have to say that while a great amount has been accomplished in terms of functionality, the user experience has not been paid due attention. The user interface is very, well, developer like :].

If we want rockbox to be truly embraced, even by the non-technical users, we need to give the user-experience a rethink, and not just a facelift.


I am a trained usability engineer and am very interested in collaborating with people interested in taking forward the UX cause.

If interested, we can collaborate online. Contact me at

ady[dot]bee[at]gmail[dot]com
This task depends upon

Closed by  Paul Louden (Llorean)
Thursday, 17 December 2009, 12:39 GMT
Reason for closing:  Not a Bug
Comment by Paul Louden (Llorean) - Thursday, 17 December 2009, 11:50 GMT
Things don't change unless someone does the work. Rather than just posting on the tracker "please come to me, and I'll tell you how to redesign your project" why not get involved on the -dev mailing list? Post specific improvements you think can be done, and patches to demonstrate how this makes Rockbox more usable.

Remember that you need to think about the UI across all targets, not just the iPod 5G. That means starting with very small, very limited monochrome screens and working up.
Comment by Aditya (adityabhandari) - Thursday, 17 December 2009, 12:05 GMT
Thanks Paul for completely mis-interpreting me. Please _read_ what is written and not interpret. I never asked anyone to come to me and solicit my help. I expressed an interest in future collaboration to make Rockbox more usable. And because I am new to flyspray, and rockbox development in general, I didn't know where else to voice my thoughts but here.

Also, being a usability engineer means that I am not at all trained to code, develop 'patches', however, I can come up with wireframes for the proposed navigation and use.

Also, could you point me to as to how and where I can be part of the "-dev mailing list"?
Comment by Paul Louden (Llorean) - Thursday, 17 December 2009, 12:10 GMT
Saying "please email me, I have advice on how you should redesign your project" is exactly what you did here. Saying "don't interpret it" doesn't really work. You said you want it re-engineered, and you said you want someone from us to email you to discuss how. You asked us to come to you. You even filed this as a "bug" when there's nothing specifically broken (except subjectively) rather than trying to approach the project through a more appropriate channel (the forum, the mailing lists).

The Rockbox mailing list is located at http://www.rockbox.org/mail/

If you're not willing to do any coding at all, though, don't expect a particularly positive response. Everyone has a personal preference for how Rockbox should be. If you can't actually show that your way is better, you're just more or less going to be another person saying "I think it would be great if..."

At the very least you'll need to be able to mock-up a UI somehow or describe exceedingly clearly how everything would work. Then, since you won't code, you'll have to find someone who actually has the time to rewrite a significant portion of the code to do it for you. Not a small task.
Comment by Aditya (adityabhandari) - Thursday, 17 December 2009, 12:35 GMT
Is there a particular reason that you seem so angry?

I explained why I logged it as a bug, I think you conveniently did not read that bit. Again, who said anything about re-engineering anything? I understand that Rockbox is a HUGE product/project and that whining about things that I don't like would not really make a difference. So, please, give me a break, I want to help, and I don't like to start off any work with hostilities.

YES, I want to contribute! Is that so hard to understand?
So, I am willing to bury the bad feelings and start over again. Let's do this in a forward-thinking way. What say?

Now that we have that out of the way.

Mock-up UIs are something that I can do. And to good detail as well. I can also make flash prototypes so that people understand exactly what I am trying to say.
Btw, I take it that you're a developer? How long have you been associated with Rockbox?

Also, would you happen to know what is the most primitive device supported by rockbox?

Thanks and Regards
Aditya
Comment by Paul Louden (Llorean) - Thursday, 17 December 2009, 12:38 GMT
As I've said twice now, please take any desire to discuss this to a more appropriate channel of communication.

Loading...