Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Drivers
  • Assigned To No-one
  • Operating System iPod Nano
  • Severity Low
  • Priority Very Low
  • Reported Version Rbutil git
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Samuel Pattuzzi - 2009-12-23
Last edited by Frank Gevaerts - 2010-12-04

FS#10873 - Unable to mount as mass storage device under Ubuntu

This happen both when HID is switched on and off. My current work around is to put the player in disk mode using the bootloader (pressing select+play). Interestingly, the device does work as a HID when that setting is enabled.

Closed by  Frank Gevaerts
2010-12-04 13:56
Reason for closing:  Fixed
Additional comments about closing:  

Fix committed as r28733

Maurus Cuelenaere commented on 2009-12-23 15:54

Please also report the Rockbox SVN revision and the exact player this is happening on.

Samuel Pattuzzi commented on 2009-12-23 15:54

Also, the revision I’m using is: r24100-091223

Samuel Pattuzzi commented on 2009-12-23 15:55

The player is iPod Nano 1g as specified in the player type of the task list.

Maurus Cuelenaere commented on 2009-12-23 15:56

Oh I didn’t see we also have the iPod Nano 2G in the player type list..

Paul Louden commented on 2009-12-23 17:11

The Select+Play USB mode is the apple USB mode. There’s no HID code there.

What is displayed on the screen?

Admin
Frank Gevaerts commented on 2009-12-23 17:34

Can you provide the output of “dmesg” and “lsusb -v -d 0x05ac:”?

Samuel Pattuzzi commented on 2010-01-02 11:20

Ok, well I realised now that if I download an actual final release, e.g. 3.4, then rather than try and deal with the USB connection within the firmware, Rockbox reboots into the OF disk mode. However, I have had it working with a version of Rockbox (probably an SVN checkout). I think finding that particular revision my take me my whole life so I will post up the above outputs for when Rockbox is dealing with usb and when the OF disk mode is.

Samuel Pattuzzi commented on 2010-01-02 11:24

This is the dmesg from the OF.

Samuel Pattuzzi commented on 2010-01-02 11:26

The output of lsusb -v -d 0x05ac:

Samuel Pattuzzi commented on 2010-01-02 12:28

The output of dmesg on r24121

Samuel Pattuzzi commented on 2010-01-02 12:30

The output of lsusb -v -d 0x05ac: on r24121

Admin
Frank Gevaerts commented on 2010-01-02 16:12

The OF dmesg reports read errors, so I suspect you have some hardware issues.
I don’t really see how that can cause the problem you see though.

Did you try to mount manually from the command line, or are you relying on GUI magic?

Samuel Pattuzzi commented on 2010-01-21 19:12

I have been relying on GUI magic. However, I must say it is usually fairly reliable. I’m sure I tried using the command line at some point. I will try again with 3.5 feature freeze branch once my January batch of exams are over (provided 3.5 won’t be released by then, does anybody know when it will be released?).

Samuel Pattuzzi commented on 2010-11-27 13:38

There hasn’t been any reply to the bug for a while but I would like to point out that this is still a problem. I will attach the latest dmesg outputs and lsusb.

   dmesg (1.6 KiB)
Samuel Pattuzzi commented on 2010-11-27 13:39

Here is the output for lsusb -v -d 0x05ac: using the rockbox software.

   lsusb (1.9 KiB)
Samuel Pattuzzi commented on 2010-11-27 13:44

Here is the dmesg and lsusb for the apple USB mode as a control. I’m afraid I have tried diffing the two and there appears to be a duplicate section in the rockbox version of lsusb. However, as I’m no USB spec expert (read: haven’t got a clue) I can’t debug beyond this but am willing for advice on how to proceed.

   dmesg (3.2 KiB)
   lsusb (3.2 KiB)
Admin
Frank Gevaerts commented on 2010-11-27 14:43

At first sight, it looks like you have a bad disk (IO errors), and the rockbox USB stack isn’t handling those properly

Samuel Pattuzzi commented on 2010-11-28 14:02

Do you reckon a reformat would solve those or should we try and debug further as it is probably still a bug?

Admin
Frank Gevaerts commented on 2010-11-28 14:12

A plain reformat won’t solve this. What might work is first finding out which specific sectors are bad and then repartitioning in a way that avoids those sectors

Samuel Pattuzzi commented on 2010-11-30 10:57

But not really an ideal solution. The I/O errors should surely be handled by rockbox.

Samuel Pattuzzi commented on 2010-12-03 13:01

Okay, here is how it looks from the rockbox side with a trace of the usb_storage.c enabled.

Samuel Pattuzzi commented on 2010-12-03 14:36

Here are the usb traces for the apple firmware and rockbox in wireshark. The procedure with the apple firmware was connect, mount, unmount, disconnect. With rockbox it was just “connect” as mounting wasn’t possible.

Admin
Frank Gevaerts commented on 2010-12-03 16:28

Could you quickly try this patch, and see if it helps? If not, another wireshark trace with this applied would be helpful

Samuel Pattuzzi commented on 2010-12-03 16:53

The patch didn’t solve the problem. Here is the new trace for rockbox from wireshark.

Admin
Frank Gevaerts commented on 2010-12-03 18:11

OK, another attempt

Samuel Pattuzzi commented on 2010-12-03 18:29
Samuel Pattuzzi commented on 2010-12-03 18:37

trace from *correct* usb port

Samuel Pattuzzi commented on 2010-12-03 18:45

The dmesg output too.

   dmesg (4.1 KiB)
Admin
Frank Gevaerts commented on 2010-12-03 20:59

This is the same patch again with my test code removed.

I really don’t see any reason why this doesn’t work. Can you mount it manually? Does it work with HID disabled?

Samuel Pattuzzi commented on 2010-12-04 11:20

Aha! Yes, this time it worked. I don’t know what I did last time.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing