Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#10881 : SANSA CLIP V1 default english.voice file prevents playback of all mp3 files

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by jasontaylor - 2009-12-27
Last edited by funman - 2009-12-30

FS#10881 - SANSA CLIP V1 default english.voice file prevents playback of all mp3 files

Summary of bug: If you add a an english.voice file the unti cannot play any mp3 files.
How to reproduce:
1. Go to ebay and pick up a snasa 1gb v1 clip.
2. Format it.
3. Download the latest (r24117) zip file from http://build.rockbox.org/data/rockbox-sansaclip.zip , (as far as I can tell, there is no way to use the utility to install, so you have to do it manually. Also, there is no stable build, just the nightly builds. Please correct me if I am wrong. Issue occurs with r24115-7. Install firmware as per pdf manual.
4. Download the official english voice file. http://download.rockbox.org/daily/voices/sansaclip-20091227-english.zip. Unpack into the correct location.
5. Download any mp3 file into the PODCAST directory. (Probably any dir would work though.)
6. Unplug, get into rockbox mode, and select any mp3 file.
7. Will not play the mp3 file. Will just stay at 0.

To “fix,” delete the english.voice file.

My opinion. Clearly, at the least, the pdf manual for the sansa clip v1 should indicate that english.voice does not work. At the most, someone here should think about how to properly fix the problem. Seems like generating a new english.voice file would be a first step.

Call me at USA 3012776O32 if you’d like to suggest anything to me as to how to fix it.

Closed by  funman
2009-12-30 17:24
Reason for closing:  Duplicate
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

 FS#10605 

The player is listed as unstable for a reason - among other things the manual is a draft.

Voice is supposed to work. The fix isn’t “fix the manual to list the bug.” Bugs are constantly appearing and being fixed.

The real problem is that the Sansa clip has very little RAM. When the voice file is loaded there’s probably not enough left for playback.

If you go into the debug menu (with the voice file loaded and playback not working) and check the buffer/playback status, what information does it show on the screen?

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Ok, started playing an mp3 file, then went to

system 
 debug
   view buffering thread

This is what I saw:

http://www.myimagehosting.com/16354c1U05-115796.pic

I do not understand what the numbers mean. The manual does not say. My guess as to what it means, 170K out of 176k is buffer use and size, 373k is allocated ram for the thread, ???? is 24k/397k, file size is 36MB, there is 1 track, three files are open, cpu is running at 62 mhz. Is that correct? Is there any other screen shots I can supply or tests I can run? Or is that showing lack of ram? Seems if there were lack of ram, it would lock up system, not not play. So I am sceptical of this theory.
Jason

I do not understand what

Wait, that is normal working playback (without a voice file), hold on 1 second while I do the fail test you actually asked for.

The RAM is split into two parts. The part the core OS uses is always the same size, so doing things like loading voice files will not prevent the core OS from working at any point (as it never releases the RAM it uses).

Meanwhile the other part is called the “buffer” and is reserved for things like the voice files, and music waiting to be played. If the buffer gets too small from things like voice files, playback may not function properly as Rockbox has shown issues with playback with very small buffers. Since the Clip has one of the smallest amounts of RAM of any player, it’s one of the few targets such a situation is realistically possible.

Another question - how large is your .voice file?

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

Ok, when the voice files are properly unpacked, and I attempt to play an mp3 file, I get

http://www.myimagehosting.com/16354c1U05-115797.pic

Note, if I then go to resume playback, it says no file is being played. So again this suggests to me that the voice file is hanging something, not that it is a memory issue.

Jason

On the other hand, the image you’ve posted basically confirms it’s a memory issue.

Do you have database loaded to RAM? You could try disabling or reducing memory usage in other areas, and creating a smaller voice file (lower quality voices) to confirm if you still doubt it, but basically it looks like playback is unable to start because there’s not memory with which to buffer the audio.

Directory of D:\.rockbox\langs

12/27/2009 03:08 AM 863,788 english.voice

             1 File(s)        863,788 bytes
             0 Dir(s)     906,395,648 bytes free

Paul, the file is 863,788 bytes. CRC32=B4CF6442.

Which is way too big for the memory available in the clip. Since it seems there’s improper handling of too-large voice files, the bug really is that it allows you to load it at all.

Paul wrote: “Do you have database loaded to RAM? You could try disabling or reducing memory usage in other areas, and creating a smaller voice file (lower quality voices) to confirm if you still doubt it, but basically it looks like playback is unable to start because there’s not memory with which to buffer the audio.”

I never started the initial catalogue of files, so the database program should not be loaded. Since it never has run I cannot go to the settings menu and force it not to load yet. Should I start it just so I can disable it?

Ok, so this is confusing. I need to make a super tiny english.voice file, perhaps one that has just one character in it. How do I do that? The thing is, the utility program doesn’t recognize the sansa clip. I could tell it to build a voice file for a different unit, and give it a fake directory, and then snag the english.voice file from it and put it on the sansa. Is that what I should do to confirm the memory theory? Also, what settings should I use in the utiulity to insure a tiny english.voice file?

You don’t need to confirm the memory theory. It’s a fact that the size of the voice file is a problem. I just offered it as a way you could convince yourself since you seem so doubtful of what I’m telling you.

Ok, Paul, it sounds like you know what’s going on. I therefore assume you have a good idea of how much memory is required, and how much memory my clip has. Paul would you mind saying what I need vs. what I have in terms of ram? (Knowing the answers will help me decide which player to purchase instead of this clip. I want something small and light (the clip is 1 oz), but would like this voice feature.)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing