Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by johnc60 - 2010-01-02
Last edited by mc2739 - 2010-01-02

FS#10888 - Sansa m200v4 abruptly shuts down as the volume is increased.

The Sansa m400v4 has a very low audio output when compared with the original firmware. Audio distortion is also noticible as the volume is increased. When increased beyond -2dB the play will suddenly turn off. Restarting the player will restore normal operation at a low (default) volume. Increasing the volume beyond -2dB will again cause the player to turn off.

The Rockbox code must be setting up the audio amp or pre-amp in some strange manner on this platform or the codec is not delivering the correct input levels to the audio amp. Even at low to moderate volume, the audio is distorted. The original firmware works fine with an incredibly loud and distortion-free sound.

Is it possible that the audio level is too low at the input of the final audio amp? Therefore, we have to crank it way up just to get a decent volume causing huge power draw and the power regulator shuts down?

To more-or-less confirm this, I disabled the backlight and I am able to raise the volume level to 0db or 1dB before the player abruptly shuts down. When re-enabling the backlight, the player shuts down at -2 dB again.

Thanks for looking into this. The Rockbox version is r23773. The problem also occurs with each of the latest daily builds. The problem is reproducible.

-John

Closed by  mc2739
2010-01-02 11:51
Reason for closing:  Invalid
Additional comments about closing:  

Unsupported player

This is a known problem as noted on the Sansa AMS Port wiki page - http://www.rockbox.org/wiki/SansaAMS#Port_Status

Since this device is not currently supported, please post this information to the Sansa AMS New Port forum thread - http://forums.rockbox.org/index.php?topic=14064.0

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing