Rockbox

Tasklist

FS#10914 - %mp (playback mode) status not updating properly in Custom Status Bar

Attached to Project: Rockbox
Opened by EW (ewillner) - Thursday, 14 January 2010, 18:50 GMT
Last edited by Jonathan Gordon (jdgordon) - Friday, 15 January 2010, 04:26 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Tested in build 24093 (e200v1) and simulator (e200v1) 24223.

Refer to attached theme.

The %mp playback mode (status) is not being updated in all cases.

I have this tag configured in my sbs for the bottom of the player. It is also configured to display the radio and recording status

To demonstrate the problem , go into the radio and toggle the play/pause button. The status does not update. However, if you exit the radio to the main menu, the status seems to show properly.

(Perhaps if  FS#10853  - radio screen skin support - is accepted and implemented, this problem with go away...)
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Friday, 15 January 2010, 04:26 GMT
Reason for closing:  Not a Bug
Comment by Jonathan Gordon (jdgordon) - Thursday, 14 January 2010, 19:03 GMT
this sounds like its because the sbs isnt updated anywhere near as often as the wps.
The sbs is usually only updated once per button press, or every few seconds otherwise (the WPS updates at 25FPS if the peakmeter is enabled, or 10FPS if it isnt IIRC).

If you toggle the play button in the radio screen and wait a few seconds does it update? or do you ave to exit the screen to get it to change?
Comment by EW (ewillner) - Thursday, 14 January 2010, 19:30 GMT
Toggling (the play button) and waiting doesn't help. Nothing gets updated until exiting.
Comment by Jonathan Gordon (jdgordon) - Thursday, 14 January 2010, 19:32 GMT
ok, I'll try to have a look this evening
Comment by Jonathan Gordon (jdgordon) - Friday, 15 January 2010, 04:26 GMT
This doesnt appear to be a bug. if you get rid of the %s on the line it works. Unfortunately i have no idea why :( I mean, I sort of do. scrolling doesnt work with lines with dynamic content, and it doesnt seem to be needed there, so best just remove that tag.

Loading...