Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Music playback
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Sascha Wolf - 2010-01-19
Last edited by Frank Gevaerts - 2010-03-05

FS#10919 - playback pause on rebuffer

Hello.

Since mid-november I have noticed a small pause in playback when a rebuffer occurs.
These are the facts:

Target: Ipod Video 64Mb, 80Gb HD, 5.5Gen

The pause is about 1 second long and occurs about 2 seconds after the Harddrive has begun to spin. Increasing the anti-skip buffer from 5 seconds to 15 seconds had no effect.

It still occurs with SVN r24281

Closed by  Frank Gevaerts
2010-03-05 10:26
Reason for closing:  Fixed
Additional comments about closing:  

fixed in r24968

Torne Wuff commented on 2010-01-20 10:59

I can’t reproduce this (same player). What codec are you using? Does it still happen if you reset your settings to default?

Sascha Wolf commented on 2010-01-29 20:26

Clearing my settings “fixes” the issue, but as soon as i set these two settings the issue reappears again (MP3 Codec, V2 - V0 VBR quality):

-enable equalizer (with a preset)
-set a theme with a reasonably big album art (FullScreen, DriveBox, Boofers etc: http://themes.rockbox.org/index.php?target=ipodvideo )

(it actually took me a week to single these settings out)

Torne Wuff commented on 2010-01-29 20:32

Hmm, I use 100×100 album art but I don’t use the equalizer. I’ll experiment with this over the weekend.

Sascha Wolf commented on 2010-01-29 20:39

100 x 100 album art is not big enough to cause the issue. It only happens on the wps with big album arts.

Douglas Valentine commented on 2010-02-04 23:39

I think I am seeing the same problem with my 80GB 5.5G Ipod video.

But the trigger seems to be using an wps such as cabbiev2 that supports album art then using a cover art that needs to be scaled down.
I don’t use the equalizer and changing to any non cover art wps seems to cure the problem, the problem also seems to trigger after pausing and restarting playback.

As I mainly use my ipod in the car it is being paused and restarted using the ipod remote I don’t know if thats relent or not but I dont have my headphones with me at the moment so I cant test if the problem also triggers when controlling playback without the remote and using the normal headphone socket instead of the remote lineout.

Torne Wuff commented on 2010-02-05 10:47

I have been unable to reproduce this problem no matter what album art, WPS or equaliser settings I use..

Torne Wuff commented on 2010-02-15 11:46

Horscht (or Dwyloc): Can you try this with a revision older than r23740? r23739 would be ideal.

Magnus Holmgren commented on 2010-02-28 13:14

Could you check if r24968 or later fixes the problem?

Ronald Malbosc commented on 2010-03-05 08:11

I’ve checked this morning, it seemed ok.
But during my trip to work, there is at most 1 or 2 buffer refills.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing