Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To
    Tomer Shalev
  • Operating System Archos Ondio
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Marianne Arnold - 2010-01-29
Last edited by Rafaël Carré - 2010-01-30

FS#10935 - Fractals only showing a full black screen with greylib

As the title says, the plugin is currently only drawing a black screen on targets where greylib is used - right from entering the plugin and zooming or moving around changes nothing. This is with revision 24365 but I saw it in slightly older builds too.

I experience this on my OndioFM (monochrome), Iaudio M5 (greyscale) and in an Ipod Mini sim, so it’s fairly safe to assume that it happens on all greylib targets. On my M5 the previous build was new enough that the older mandelbrot.rock still work and it does not have this problem.

Fractals works on my c200 which has a colour screen but I have to admit that I don’t like the new colours much because it’s now a much smaller colour “range”. Of course, that’s not the bug but maybe it has to do with it?

Closed by  Rafaël Carré
2010-01-30 07:16
Reason for closing:  Fixed
Additional comments about closing:  

r24377

Bertrik Sikken commented on 2010-01-29 09:54

I can confirm this for the Sansa Clip too, it also uses greylib for the fractals plugin.

Dominik Riebeling commented on 2010-01-29 18:46

Confirmed on H100 (r24364), m:robe 100 (r24370) and Mini2G (r24255). Mini2G shows a white screen, all others a black one.

Rafaël Carré commented on 2010-01-30 06:24

r24309 didn’t had the intended effect:

  Fractals: this should fix bugs on simulator for greyscale LCD targets.
  * moved #define USEGSLIB to fractal_sets.h and include only needed header file.
  * include plugin.h so that LCD_DEPTH is defined.
  * explicitly include fractal_sets.h in mandelbrot_set.c
  
Rafaël Carré commented on 2010-01-30 07:04

bug wasn’t in the sim but in the colors calculation = all colors were 0

Rafaël Carré commented on 2010-01-30 07:11

And yes color range is weirdly done, I don’t quite get what max_iter really is.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing