Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Rbutil git
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by piotrekm - 2010-01-30
Last edited by bluebrother - 2010-09-05

FS#10938 - rbutilqt won't compile on OS X Snow Leopard due to lack of ppc support in some libraries

The problem is that on Snow Leopard, i assume, some libraries are deprived of the ppc part while rbutil still requires them while compiling.
It would be nice to have the -arch ppc removed from Makefile in case compilation takes places on Snow Leopard. Make process got through without problems after I manually did so.
I used files from revision 24373.

Closed by  bluebrother
2010-09-05 09:48
Reason for closing:  Not a Bug
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

This is really not a bug but a problem of the build setup (see my comment). However, I've now added a -config intel option to the qmake call which changes the project to target OS X 10.5 Intel only. Doesn't change the used libraries, but it builds fine for me using macx-g++ as spec.

Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557

I can build Rockbox Utility fine on Snow Leopard (the svn binaries I’m providing at http://tinyurl.com/rbutil-dev are built on SL). Please be more detailed with the problem description, compiling also requires to use the correct QMAKESPEC value (the default, at least for Qt 4.6.0, doesn’t work. See the deploy-release.py script for details).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing