Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category LCD
  • Assigned To No-one
  • Operating System Sansa c200
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by BlastTyrant - 2010-02-04
Last edited by Bilgus - 2024-04-23

FS#10966 - c200 v1 LCD doesn't turn on when changing Backlight setting from Off to On

As the title states the c200 v1 LCD doesn’t turn on when changing the Backlight setting from Off to On. The backlight itself does turn on though. I don’t know if this happens with the v2 players.

I first noticed this behavior in r24404 earlier today on my c240. I then updated the player to r24511-100204 and get the same behavior as before. I also get the same behavior in another c240 v1 player that I have which I also updated to r24511-100204. It was previously running r20698-090412 and the backlight didn’t turn on when changing the backlight from off to on (I’m guessing that  FS#10130  fixed that problem) - so it happened sometime between that revision and at least as far back as r24404. It might have even carried over from  FS#10130 .

Also, just as a note, I don’t notice this behavior in the February 2nd c200 simulator (r24449) - both the backlight and LCD turn on as expected. I checked my v1 Fuze (r24509) also and get normal behavior (backlight and LCD turn on), so this bug might just be limited to the c200 players.

Closed by  Bilgus
2024-04-23 04:44
Reason for closing:  Out of Date

I can confirm this for my c200 v1.

Something similar happens to my e200v1 as well: when switching from off to on, it sometimes (1 in 5 or so) comes up with a completely white screen.

I can confirm this behavior on my e200 as well.
To produce the bug enter lcd settings backlight scroll up to "off" then back only once to "on" the screen remains all white until the wheel is scrolled farther or another button is pressed. This has a very low importance compared to some other bugs though.

Thinking further probably caused from the frame buffer getting flushed when the screen is blanked. Free flash light feature?

@any_devs: Could this be related to  FS#11756 ?

r23730 is the commit that causes this bug (confirmed on both e200v1 and c200v1)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing