Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category LCD
  • Assigned To No-one
  • Operating System Iriver H300 series
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Chiyo-chan - 2010-02-15
Last edited by jdgordon - 2010-03-03

FS#11015 - Main LCD WPS refresh on first keypress

Hi,

On a recent build (last week, but I’ve seen it for quite some time now) on a iRiver H3xx, with “First Keypress Activates Backlight only” activated, on the main LCD (the remote one’s ok), the wps info (title, artist, etc.) isn’t refreshed with the first keypress and the backlight kicks in. The infos displayed are the ones from when the backlight got off. You have to go to the file browser and then back to the wps to refresh the screen.

Thanks in advance.

Closed by  jdgordon
2010-03-03 00:02
Reason for closing:  Duplicate
Additional comments about closing:  

 FS#10926 

Can you reproduce this in 3.5 as well?

I've jsut checked. Here is the result :
- r24601 : album art, progress bar, all the time infos get updated, but track infos like artist name, track title, album, year, genre don't change. Next track shows the track that is currently playing.
- v3.5 : same result.

Looks like this is the same problem as I have reported in 11024.
Also with "First Keypress Activates Backlight only" _not_ activated the WPS is not updated when a key is pressed.

Same as what I reported in  FS#10926  - Backlight off causes track info to freeze :-) Over a month ago!

I don't know if it's reassuring or scary to know I'm not alone ^^

this is almost certainly because the backlight off is stopping the full refresh that happens on track change. what needs to happen is either a refresh happens while the backlight is off, or (probably better) do the refresh when the backlight comes back on

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing