Rockbox

Tasklist

FS#1105 - Extreme Loading Times

Attached to Project: Rockbox
Opened by Nick Snider (sgtscruffy) - Sunday, 16 March 2003, 04:56 GMT
Last edited by Björn Stenberg (zagor) - Tuesday, 15 April 2003, 22:46 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am using rockbox version CVS-030315, on an Archos
Jukebox FM Recorder, OS version 1.30j.

I am having a problem similar to the one here:
http://sourceforge.net/tracker/index.php?func=detail&group_id=44306&atid=439118&aid=664793


I try to open a song, but it takes about 30 seconds.
It will sort of hang at the song folder, and then the
screen will go blank exep tfor the clock and the top
bar, and it will hang there for about 10-15 seconds,
and finally start playing.

If I press the skip track button, it does the same
thing; It plays the song for about 3 more seconds,
then just hangs on the song info for about 20 seconds.

Unlike this case, I have tried waiting 30 to 40 seconds
into a song, but it still did the same thing.
This task depends upon

Closed by  Björn Stenberg (zagor)
Tuesday, 15 April 2003, 22:46 GMT
Reason for closing:  Fixed
Comment by Björn Stenberg (zagor) - Monday, 17 March 2003, 07:19 GMT

Please supply a file with which you see this problem.
Comment by Nick Snider (sgtscruffy) - Monday, 17 March 2003, 21:46 GMT

I attached the newest Daily build file (3/17), which still
doesnt work.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 17 March 2003, 23:33 GMT

We don't want the firmware file, we already have it, as we
are the ones who make them. We want the MP3 file that you
have trouble playing.
Comment by Nick Snider (sgtscruffy) - Monday, 17 March 2003, 23:35 GMT

Oh, sorry, misunderstood ya.

It happens with every mp3 on my player (I have tons)
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 17 March 2003, 23:42 GMT

It works perfectly for me on my FM recorder. Can you tell me
a little about your MP3 files, like how many you have in
each dir, how big they are, bitrate etc?
Comment by Nick Snider (sgtscruffy) - Tuesday, 18 March 2003, 01:12 GMT

OK. While I was counting directories and such, I discovered
a few things that might make it go wrong. For one, in my
root directory, I had 70 folders, so I split them up. Also,
in a few folders, I had more than 40 mp3's, so I got it to
below that, but it didnt work. Most mp3's are 128 kbps, and
from 3-6 megs each.

The files in each directory can be as few as about 2, to as
many as 35 (now that I have pruned them). However, the
problem still persists.

Currently I have about 50 Folders.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 18 March 2003, 01:31 GMT

OK, looks normal to me.

Anything special about your MP3's?

Are they tagged with the same program?

Do they have huge cover bitmaps in the tags?
Comment by Nick Snider (sgtscruffy) - Tuesday, 18 March 2003, 01:35 GMT

Most are tagged by Winamp, the ones I have ripped from CD's
(using CDEX) had the info downloaded from the CDDB. Nothing
special that I can think of...

What doy ou mean by huge cover bitmaps in the tags?
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 18 March 2003, 01:50 GMT

Very strange. I can't think of a good explanation for this.
Have you run scandisk lately?

About the huge cover bitmaps, some people like to put
scanned JPEG/BMP pictures of the album covers in the ID3V2 tags.

I would still like to examine one of your files, just to be
sure. Can you attach a small one to this bug report?
Comment by Nick Snider (sgtscruffy) - Tuesday, 18 March 2003, 02:34 GMT

I have not run scandisk recently, but I am now. I have
attached an mp3 from my hard drive that is on the player (I
cannot add it directly from the player as it is scan-disking)
Comment by Nick Snider (sgtscruffy) - Tuesday, 18 March 2003, 02:37 GMT

I have not run scandisk recently, but I am now. I have
attached an mp3 from my hard drive that is on the player (I
cannot add it directly from the player as it is scan-disking)
Comment by Nick Snider (sgtscruffy) - Tuesday, 18 March 2003, 02:45 GMT

Sorry, uploading didnt work, heres a link (uploaded to my
web site)

http://members.cox.net/brain-warp/05-(I%20Just)%20Died%20in%20Your%20Arms%20-%20Cutting%20Crew.mp3
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 18 March 2003, 08:08 GMT

I just tried your file, and (as expected) it worked fine on
my FM recorder. I wonder what it can be...

How does your hard drive sound when you start the song?

Does it behave differently if the drive is already spinning
when you start the song?
Comment by Nick Snider (sgtscruffy) - Tuesday, 18 March 2003, 22:59 GMT

I ran scandisk (took overnight) and it still did it... When
I start a song, it will make rapid click sounds, about five
per second, until the song starts, and it is silent.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 19 March 2003, 07:40 GMT

...and the original firmware works perfectly?
Comment by Nick Snider (sgtscruffy) - Wednesday, 19 March 2003, 18:17 GMT

Yup, works fine for me.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 19 March 2003, 20:44 GMT

Then I have no idea what may be causing this. When did you
start having these problems?
Comment by Nick Snider (sgtscruffy) - Wednesday, 19 March 2003, 21:47 GMT

As soon as I installed the rockbox stuff. I guess I will
just have to use the original firmware. Oh well. Thank you
for your help, though. Sorry to take your time :)
Comment by Anonymous Submitter - Saturday, 22 March 2003, 17:45 GMT

I can confirm this problem on a Jukebox Recorder 20 using the
CVS version from March21 as well as an older CVS version (I
no longer have the specific date on that one, it's from the
beginning of March).




Further info:


The specific symptom of the problem is that it takes 4-5
seconds to start playing a file. The same delay occurs on
changing from one file to the next using FF or rewind. It does
not happen when one song ends and the system moves on to
the next in a directory (haven't tested it with playlists yet).




I do not see this problem with either the RockBox release (v1.
4) or the Archos firmware (v1.28).




It happens with *every* MP3 I've tried, from 160KB files
encoded with musicmatch or winamp to 128KB files from
emusic.com.




It occurs even on directories where there are only 3 files.




Comment by Anonymous Submitter - Saturday, 22 March 2003, 17:47 GMT

damn, forgot to attach an email address to that last comment:
greglandrum at earthlink dot net




I'll be travelling for a few days starting tomorrow, but I'll be
checking email if you want more info.
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 13 April 2003, 22:27 GMT

How does it work for you with the latest daily build?
Comment by Nick Snider (sgtscruffy) - Sunday, 13 April 2003, 23:52 GMT

Works like a charm, thanks!!
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 13 April 2003, 23:55 GMT

Wonderful. I'll set the status to "fixed" then.
Comment by Nick Snider (sgtscruffy) - Monday, 14 April 2003, 00:16 GMT

Wait.... damnit. It broke..

It worked, but then I added some mp3s, and then it does it
again.

When there can only be 40 files in a directory, does that
include folders (like, if the main directory has like 80
folders?) I tried setting it so there isnt more than that
in the main directory, but it still does it.
Comment by Nick Snider (sgtscruffy) - Monday, 14 April 2003, 00:21 GMT

and now it DOES work! oh the humanity!

I guess I just have to replace the file whenever I add an
mp3. Ok, hopefully it is fixed. Thanks again for all your
help :)

Loading...