FS#1108 - FM Recorder locks up during playback

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 17 March 2003, 13:58 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Saturday, 13 March 2004, 21:47 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Archos Jukebox FM recorder 20GB
Archos os firmware 1.30J
Hardware info ROM 1.23
Mask 0x0304
USB positive
ATA 0x200
PR positive
Freq 11.0592MHz
rockbox version CVS-30316

During normal (not-playlisted) MP3 playback, the unit
will lock up and stop playing the MP3. It does not
occur at a repeatable point within the playback, nor
after a repeatable number of tracks. It is to all extents
and purposes random, however it usually occurs
within playing the first 5 tracks.

The problem seems worse when the unit is in shuffle

When the unit stops playing, the disk access light is
a constant green. Pressing keys operate the backlight
but do not perform their correct function, they do nothing.

The only way to continue is to reset the unit by holding
down the "STOP" button.

This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Saturday, 13 March 2004, 21:47 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Logged In: YES

This sounds like a duplicate of #622799. I'm closing this one.
Comment by Mike Holden (mikeholden) - Monday, 17 March 2003, 14:12 GMT

This is a known problem, and has been reported before. The disk led -
red, not green! The green one is on all the time.

The main problems occur when the unit is being carried, rather than
when placed flat on a solid surface.

There have been several improvements recently, so make sure you
are using a recent build.

This is a duplicate bug report.
Comment by Anonymous Submitter - Tuesday, 18 March 2003, 07:49 GMT

Hi, I have also had the problem when the unit is placed on a
flat surface. Using CVS-30316 so that is fairly recent.

Comment by Timothy May (mayday6971) - Thursday, 22 January 2004, 06:10 GMT

I am getting this problem. I was using the daily CVS builds
pre 2.1 and now with 2.1. I am using the Recorder model and
I removed the rockbox file from the root of the hard drive at
it works fine without a disk lookup. Any ideas?
Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 22 January 2004, 09:24 GMT

You guys should really try the post-2.1 daily builds. We
believe we have fixed this problem.
Comment by Timothy May (mayday6971) - Thursday, 12 February 2004, 21:00 GMT

FYI, I have tried the daily build as of today 2-11-04 and it
still happens. I can confirm it does not happen with the
factory player. I can go from 100 to 5 on battery with no
lockups. I usually only get 3 - 5 minutes of playtime and it
locks up.
Comment by Anonymous Submitter - Friday, 12 March 2004, 17:11 GMT

this problem is also known to rockbox v2.1 running on
jukebox studio 20.
after a few minutes playback will continue as nothing has
as soon as it resumes playback the unit's full functional again.
maybe a buffer problem.
Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 13 March 2004, 21:47 GMT

This sounds like a duplicate of #622799. I'm closing this one.