FS#11090 - Stkov-error when trying to stop/shutdown Rockbox on iPod nano 2G

Attached to Project: Rockbox
Opened by Stefan (hale-bopp) - Wednesday, 10 March 2010, 15:37 GMT
Last edited by Michael Sparmann (TheSeven) - Thursday, 11 March 2010, 17:37 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod Nano 2G
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Tested on: r25098-100309

When I'm playing audio-files with Rockbox on my iPod nano 2G (4GB) and hold pause for a few seconds to stop them and shut down Rockbox, I get a grey screen showing:
Stkov 3C4D3C36

I encountered this problems with Rockbox-firmwares that support cpu-boost, older ones like r24635-100213 work without any problem so I started using them again.
The curious thing is that this error occurs only when I played audio-files before, if I just turn on my iPod and then shut it down again without playing any file, there won't occur that error.
This task depends upon

Closed by  Michael Sparmann (TheSeven)
Thursday, 11 March 2010, 17:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  Stack has been enlarged for now
Comment by Michael Sparmann (TheSeven) - Wednesday, 10 March 2010, 16:36 GMT
As it doesn't happen for me, can you try to figure out which exact revision is causing it? Which revision is the first one that fails?
Comment by Stefan (hale-bopp) - Wednesday, 10 March 2010, 17:19 GMT
As far as I tried was every daily build above r24635-100213 causing this error (I tried r24802-100220, r24803-100221, r25083-100309 and r25098-100309). I don't know if it has anything to do with the new cpu-boost feature but that was the only change I recognised. Perhaps my iPod is also broken, it's a bit catchy to get it started due to a white-screen-of-death-problem, but I got a kind of workaround with iLoader and your great Rockbox-firmware!
Comment by Michael Sparmann (TheSeven) - Thursday, 11 March 2010, 01:22 GMT
Hm, so it still can be anything from r24636 to r24802... That doesn't really help tracking it down, I can't look through 166 commits whether I spot something suspicious.
Regarding iLoader, did nandfsck do its job well after those crashes or did it fail sometimes?
Comment by Michael Sparmann (TheSeven) - Thursday, 11 March 2010, 03:00 GMT
I increased the stack size for now. Does it work with the latest revisions again?
Comment by Stefan (hale-bopp) - Thursday, 11 March 2010, 13:39 GMT
Hi Michael,
I changed to version r25112-100311 and now the problem is gone! I can shutdown Rockbox without any problem again, thank you very much!