Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To
    TheSeven
  • Operating System iPod Nano 2G
  • Severity High
  • Priority Medium
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by MoSPDude - 2010-03-11
Last edited by TheSeven - 2010-03-14

FS#11092 - Nano 2G 8GB PANIC in FTL

After changes to yesterdays SVN (probably related to r25099) , I’ve started to receive messages like,

*PANIC*
FTL: Scheduling bank 2 block 6214 for remap!

on my 8GB Nano 2G when I play certain songs, after around 3 seconds into the track. I can’t see a link with the songs that are played, but it is the same songs and reproducable. I’ve had it report bank 1 blocks for remap as well. I’m currently on the r25112 daily build.

Closed by  TheSeven
2010-03-14 20:49
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r25181

I confirm. After installing r25111 I’m having this error on my nano 2g 4GB too.

I tried Daily Build which is r25109 and it gives the same error ;/
Please do something with this because I don’t have any older build so i can’t actually use my Ipod.

Oh well, looks like the performance improvements backfired. (r25099)
I would have rather expected that kind of trouble to show up on writes, not reads, though.
And once again, I can’t even reproduce it :-/ Can you have a look in the System ⇒ Debug ⇒ View HW info screen and tell me the values from the “NAND” section?

I made two builds who use a safe-slow-stupid approach when accessing the flash to a different degree. Can you please check which of those fix the problem for you?
You can find them here: http://www.file-upload.net/download-2338259/rockbox-nandworkaround.zip.html

I’ve installed a fresh r25127 (no database, using the default settings, just selected the file directly to play it) and tried both the nandworkaround builds - with no success. The same file returns the same PANIC statement (same bank and block) each time.

My NAND information is:
banks: 4
bank: 0, id:A585D598
bank: 1, id:A585D598
bank: 2, id:A585D598
bank: 3, id:A585D598
sectors: 3964928
sector size: 2048
last disk activity: 149

When I get home to my own computer this weekend, I can perform my own builds if passing patches is easier for you?

Hm, seems to be always the same chip that’s causing trouble, maybe we should just adjust some timings for that one… I’ll check.
I can’t really explain why both of these builds fail though, as the -safe one is basically doing what rockbox used to do before the performance improvements, at least for reading.

It would be awesome to get this sorted. I’m not a programmer or anything, but if there’s anything I can do to help (try beta versions etc) I’ll be more than glad! I did download the new nandworkaround fix.ipod, Should I perhaps try that for you and post the results?

Yes, that would be helpful. Also look up your NAND chip IDs as described above, but I guess it’s the same.

alrighty…

I’ve installed the Nandworkaround “safe”. I haven’t had much time to test yet, but here is my Nand info:

banks: 2
bank 0. id: 2585D3AD
bank 1, id: 2585D3AD
sectors: 991232
sector size: 2048
last disk activity: 140

is that what you need?

yes, that’s what I need, but I wouldn’t expect any problems with that chip. Are you sure that you are experiencing the problems mentioned here? (FTL spuriously trying to remap blocks)

so far, the nand slow workaround hasn’t crashed. Playing 64kbps AAC and 128 kbps MP3.

But, it does pause every 50seconds or so (a quick 1sec dropout) when playing back the AAC. Perhaps thats a byproduct of the nandfix ‘slow’ file?

I’ll give this another 30min of listening, and then try the nandfix’fast’ file as comparison.

This was my initial panic message and crash that eventually led to this particular bug report:

*PANIC* FTL: Scheduling Bank 1 block 1906 for remap!

from here: http://forums.rockbox.org/index.php?topic=24161.msg163466#msg163466

Dang! Just got another one after hitting stop.

*PANIC* FTL: Scheduling bank 1 block 3682 for remap!

OK, I finally have an idea what could be going on here… Sadly this will probably mean there won’t be fast NAND access for you as your chips just don’t support it.
Nevertheless both of those files should work for reading, just not for writing…

:(

does that mean 9 seconds between hitting a button, and the relative action?

Well, that’s fine for me…as long as I have no more panics/freezes/restores, I’ll be happy. I just want my ogg and my 5-band EQ!

Lemme know when there’s something new to test! :)

Richard 9 seconds? It’s much bigger than mine(2, 3 seconds max. )
I have
banks: 2
bank 0, id: A585D598
bank 1, id: A585D598
sectors: 1982464
sector size 2048

So Michael, are you able to make the newest build working for us?(without fast NAND access of course)

Possible fix… Please report if it helps!

If the file above still didn’t work, try this one:

Alrighty…thanks!

I’ve downloaded the second file (520.5Kib), and it’s installed with the latest Rockbox build via rbutilqt.exe

Here I go!! Playing songs now….

So far so good through 3 songs.

Also. when playing a song (64kbps AAC) and then going back to the database window…it shows “searching…160 found PLAY/PAUSe to abort” for about 30 seconds, each time I goto database (even after re-booting from initial database initialization). I’ll try loading database to RAM and see if that helps….

Ah ha!! Loading into RAM works perfectly…instant!!

I’ll continue testing for the next 30 min before my next client arrives!

Thanks for all your work! You’re awes!

after 20 min of playing non-stop..it’s still going strong!

but, I’m still getting the odd sound dropout on M4A files (AAC). every 60sec or so, the sound would stop for 1sec and then continue again…

Reopened due to  FS#11098 

Re  FS#11098 : Please re-copy that file to your iPod to make sure that this isn’t just some residual damage from before the patch was applied, as the bug actually was in flash *writing* code.

I’m just testing the latest SVN now - and I can confirm it’s not working on mine. I am now on my build machine so can test patches.

I’ve reverted to r25098, and the same files work correctly. I’m going to clear it all off, start with a fresh SVN head install, and copy it back - but it’ll take a bit of time then to find a file that causes the problem.

Oh damn. Looks like there were actually *two* problems at the same time, both of which depend on the NAND chip type. It’s always those Toshiba chips, they’re just evil…

Alrighty…I think my little stopping issue mentioned a few posts back is due to AAC and/or low-bit conversion.

When playing 64kb AAC/M4A files…i get the stopping/cutting-out sound issue, plus everything is really slow to respond (jog wheel, etc) takes forever. But, when playing regular 128kB MP3s, it’s working perfectly.

Still doing more testing here…will keep you posted (as long as this remains open).

rdolmat - just a thought, but have those AAC files ever played without cutting out, for you? Your cutting out issue may be unrelated entirely to this NAND issue. I would imagine that, for you, 64kbps MP3s would work just fine. HE-AAC files, in particular, are notoriously CPU-intensive and will cut out on almost all rockbox-support targets - see here http://www.rockbox.org/wiki/CodecPerformanceComparison (and note in particular the first line in the Nano2G table where the 64kbps HE-AAC/M4A codec runs barely above 100% realtime - that file format *WILL* cut out during playback)

Hi Dave.

No, they sound fine elsewhere, but I think as TheSeven mentioned to me, it’s just too intensive of a codec to use for Rockbox. But that’s alright, I’m not married to them ;)

Ogg, MP3, etc are just as good for me…either way, I’m still really happy with this latest test build for my Nano 2G. Not a single crash/freeze in a few hours now!! yeahooo!!!

dang!!

Just got another PANIC….

Listening to your standard MP3 file. 128kbs. stereo…I was set on shuffle and was clicking through to next song fairly quickly (within 2 seconds of the current song starting, I would click next, next, next trying to get to a good song).

and then…

*PANIC* FTL: Scheduling bank 1 block 836 for remap !

:(

Did you delete and copy those MP3 files again after updating to the fixed revision? If not, this *might* be residual damage…

Hi Michael,

Yes.

These are all brand new MP3 loads into the unit.

Damn. I think I’ll revert this whole bugger for now, and we should try to split it into several consistent subset patches and check those individually…

r25099, r25101, r25109 and r25137 have been reverted in r25139. The problems should be gone again. Nevertheless, I would like to further debug this, as this patch should really go in…

Is there anything I can do in the meantime?

Should I keep with the rockbox.ipod (520.5 KiB) version, or re-install r25139, or anything?

As the patched version above (which is equivalent to r25137) didn’t work for you, I would suggest using r25139 until the problem is fixed.

Can you please check if the latest build (r25157) is having trouble again? If yes, can you check if r25156 is fine?

I’ve been using r25142 all day now…and not a single PANIC yet.

Playing 128 Kb MP3. Using disc-mode to transfer files.

I’ll try the latest r25157 anyway. I can install and use it for an hour or so today to help out.

where do I get r25157…all I can see is r25160 :(

I don’t know how to compile the c code…

DANG! I installed r25160..and within the first 3 seconds of the first song I played…

PANIC FTL etc.etc…same thing…block 491 for remap!

back to r25142 again.

r25157 - fails with same FTL errors above.
r25156 - success so far, though I’ll have to run this build for a day or so.

With r25165, the message is now,

*PANIC*
FTL: VFL fast read failed, RC 0000, bank 2, RET 100, base 2898432

r25142 still going strong for me! (Nano 2G)

about 4 hours total playing time since yesterday. pause, play, shuffle random fast button clicking etc….pretty stable!! very happy. Not a single panic.

(except, bookmarking doesn’t work. I would make a bookmark,and then afterwards I’d try playing back the same or different song, and nothing would play. All song lengths say 0:00 until soft reboot)

Fast reading was reverted, but I have enabled fast writes now. Can you please re-check r25173?

Holy crow…these builds are quick!

Where do I get older versions (ie: r25173)?, the main build on the front page is already at r25175!!

can you check r25176 (or later)?

Will do!

Downloading r25181 now and installing.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing