Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Games
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by potato-head02 - 2010-03-18
Last edited by stripwax - 2010-03-19

FS#11125 - pac box error

i am trying to use music playback in pacbox.
i can play music in the playback menu on pacbox. but i can’t go back to the game.
i get a glitch or a white screen with some code error. when i do so.
please fix.
sansa fuse rockbox 3.5.1
original sansa frimware v01.02.26a

Closed by  stripwax
2010-03-19 23:29
Reason for closing:  Fixed
Additional comments about closing:  

r25251

You say this is a problem in rockbox 3.5.1 and Release 3.4 - which is it?
Also are you running a custom build? I didn’t think there was a playback menu in Pacbox in the release builds (FS#8226 was never committed).
Finally, it would be very helpful if you could state (exactly, verbatim) what the error message says. The error message usually tells the developer what the problem was, so that it can be fixed.

ok
when i use playback control in pac-box i click left to the pac box main menu and the music still plays and when i click left again to go back to the game i get a video glitch.
and when i try to restart in the pac-box main menu with music playing i get a white screen with” prefetch about at fffffffe” then i hit a button and it reboots.

Thanks - so it looks like that menu option shouldn’t be there - we will remove it - it should not be possible to play audio at the same time as running pacbox. Basically, pacbox and audio playback can’t run at the same time. I don’t know why the playback control is there, it shouldn’t be, and I will remove it.

When you run pacbox, do you observe that audio playback stops? That is actually by design - to prevent the crashes that you are seeing! - I will remove the playback control from the menu, so that you cannot accidentally turn on audio while running pacbox, which will cause it to crash.

Resolved in r25251. Playback Control menu removed from pacbox.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing