Warning: Undefined array key "useheading" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 1099 Warning: Undefined array key "target" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 Warning: Trying to access array offset on value of type null in /home/rockbox/flyspray/plugins/dokuwiki/inc/parser/xhtml.php on line 557 FS#11138 : Improve detection of MTP devices

Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Rbutil
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Rbutil git
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by bluebrother - 2010-03-22
Last edited by bluebrother - 2011-06-05

FS#11138 - Improve detection of MTP devices

Several players support both MTP and UMS in the OF. Rockbox Utility already detects this for h10 and e200 and displays the user a notification about the problem. Other players aren’t handled yet, like the e200v2. See http://forums.rockbox.org/index.php?topic=24260.msg163992

Extend support for MTP player detection (via USB IDs) and warning about the need to change the USB mode.

Closed by  bluebrother
2011-06-05 11:29
Reason for closing:  Not a Bug
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

some parts had been done. Reworking autodetection is still necessary and on my list but no need to keep that open.

e200v2 already has the mtp ID in rbutil.ini, not sure what happened to the guy in the forum thread:


This is most likely caused by the configuration dialog being too short sighted: see Config::autodetect(). For devices that are not handled here but return an usberror no useful error message gets displayed. Hence the task, so I don’t forget improving this.

  • This has been added to some degree.
  • See svn before 1.2.10

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing