FS#11144 - Play count updates

Attached to Project: Rockbox
Opened by Mantas (grawity) - Thursday, 25 March 2010, 21:07 GMT
Last edited by Mustapha Senhaji (DrMoos) - Thursday, 25 March 2010, 22:32 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


It seems to me that Rockbox play history and /.scrobbler.log are updated whenever a track _starts playing_ - which makes no sense at all: If I skip a track at 0:02 or so, it shouldn't be considered as "listened to". It makes the "popularity" counters useless.

It would be much better if Rockbox waited for _at least_ 50% (66%, 75%?) of the track to be played.

version: r25247-100318/ipod/nano/2g
This task depends upon

Closed by  Mustapha Senhaji (DrMoos)
Thursday, 25 March 2010, 22:32 GMT
Reason for closing:  Not a Bug
Comment by Mantas (grawity) - Thursday, 25 March 2010, 21:17 GMT
After some research, I found out that tracks in scrobbler.log are marked as "skipped". I guess the task can be closed as invalid :\ (although I'm still not sure about the popularity counter)