Rockbox

Tasklist

FS#11194 - Text Viewer: Font Load & Settings

Attached to Project: Rockbox
Opened by Hunter Ragnarok (G4Oblivion) - Saturday, 10 April 2010, 21:34 GMT
Last edited by Tomer Shalev (tomers) - Wednesday, 14 April 2010, 10:56 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just updated to the most recent Daily build (r25569) from r25548 and I have a few problems...

When I view a text file everything seems normal, then when I quit the text viewer and shutdown rockbox and go to view the text file again it gives me this warning "Font load failed" and then it turns off the Header and Footer, changes scroll by to lines instead of default pages.
I tried to turn the settings back and it worked, but then when I shutdown again it gives me the same error message and reverts all the settings.
This is extremely annoying.

Another problem..

When I try to set a bookmark to a blank line (no text) it doesn't show the line highlighted like normal.
The bookmark is there, I can remove it, just it doesn't show the bookmark highlighted.

Using iPod Nano 2G
Tried this on mutliple text files and have the same problem.
Using Daily build (r25548)

I just updated so I did not change any settings with the font or text viewer.
Using Cabbiev2 with Adobe helvetica font.

If you need more information just ask.
This task depends upon

Closed by  Tomer Shalev (tomers)
Wednesday, 14 April 2010, 10:56 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Solution was proposed. No further response from author.
Long term solution to the problem is already committed.
This issue only relevant to people upgrading from any version in between 25400 (Mar 30) and 25563 (Apr 10), but to them there is nothing further that can be done other than deleting the viewer's settings file.
Comment by Hunter Ragnarok (G4Oblivion) - Saturday, 10 April 2010, 21:50 GMT
Sorry I forgot to add how to reproduce.

1. Open a text file with the text viewer and scroll down a few pages.

2. Quit text viewer and shutdown rockbox.

3. Open the text file again.

You should have the "Font load failed" warning and all the settings will be changed.
Comment by Tomer Shalev (tomers) - Sunday, 11 April 2010, 04:58 GMT
> I just updated to the most recent Daily build (r25569) from r25548 and I have a few problems...
> When I view a text file everything seems normal, then when I quit the text viewer and shutdown rockbox and go to view the text file again it gives me this warning "Font load failed" and then it turns off the Header and Footer, changes scroll by to lines instead of default pages.

Revision r25400 broke backward compatibility of the text viewer settings file. Revision r25563 fixed that by increasing settings file revision number and by providing backward compatibility logic.
Since you initially used your player with revision r25569, which is in-between these two versions, it store a setting file which was newer, but still contained the old version number. Your upgraded version thinks the setting file is of the old format and tries to read it as such, which is wrong. It messes up all settings, and cause the viewer to be in undefined state. This is what caused all the artifacts you have observed.

The simplest way to fix this would be to delete the settings file .rockbox/rocks/viewers/viewer*.dat

--------
Reference:

The relevant commits:

http://svn.rockbox.org/viewvc.cgi?view=rev;revision=25400
"Viewer: Implement alignment option, to provide alignment of RTL text (Hebrew, Arabic) to the right"

http://svn.rockbox.org/viewvc.cgi?view=rev;revision=25563
"The version of the setting files are raised. Settings can be normally read even by the old setting file."

Loading...