Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by masterh - 2010-04-21
Last edited by bertrik - 2010-07-16

FS#11214 - Scrollwheel problem with Sansa Fuze and latest versions of Rockbox

I upgraded to the 3.5.1 Rockbox firmware with my Sansa Fuze v1. I’ve been using Rockbox the last few months without any problems.

About a week after updating, I started having severe problems with my scrollwheel’s sensitivity. Sometimes, it would work fine, and sometimes, I’d have to really work to navigate menus - the wheel moved fine mechanically, but it seemed extremely unresponsive. Sometimes I couldn’t get any response at all unless I actually clicked the wheel buttons.

Sounds like a mechanical problem to me, and I was thinking I’d somehow broken my Fuze… but before I replaced it, I tried going to Sansa’s official firmware, which fixed the problem completely.

I’ve used version 3.5.1 and tried the latest build, but both seem to bring back the scrollwheel problem.

Closed by  bertrik
2010-07-16 09:11
Reason for closing:  Not a Bug
Additional comments about closing:  

Closing because this seems to be a problem with the hardware of this particular unit.

There is a delay loop just before reading buttons/scrollwheel in function dbop_read_input in file dbop-as3525.c. I think this delay should be moved slightly, maybe this also fixes your problem.
I’ll try to post a patch this evening (I don’t have a fuze to test myself).

After a few days, I’ve started having the same problem with the official Sansa firmware (though rarely and nowhere near the extent of the problem with the Rockbox firmware), which is telling me this might be a mechanical problem after all. If no other users are reporting this bug, it might just be a problem with my unit.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing