FS#11248 - Daily build r25836 crashes player

Attached to Project: Rockbox
Opened by Richard Schofield (reszerve) - Friday, 07 May 2010, 00:13 GMT
Last edited by Paul Louden (Llorean) - Friday, 07 May 2010, 06:23 GMT
Task Type Bugs
Category Configuration
Status Closed
Assigned To No-one
Operating System Gigabeat S
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Daily build r25836 100505 crashes gigabeat S at random times after booting.

White screen appears, noted "undefined instruction at 0015F560" on three occasions before player shuts off after white screen.

Doesn't seem to be related to activity. If you try make it crash, it can hold out for minutes. Or it can crash a few seconds after boot with no user action. Or at any time!

Under boot USB mode I ran Windows CHKDSK on drive - no errors found. Then restored previous daily build r25814-100504 and confirmed no instability with this version.
This task depends upon

Closed by  Paul Louden (Llorean)
Friday, 07 May 2010, 06:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  Bug report filed after bug was fixed.
Comment by Michael Chicoine (mc2739) - Friday, 07 May 2010, 01:59 GMT
Please try a newer build. According to the svn log, r25837 should have fixed some stability issues on the Gigabeat S.
Comment by Paul Louden (Llorean) - Friday, 07 May 2010, 05:27 GMT
You should update to current SVN before filing bug reports - often very obvious problems like regular crashing gets fixed fairly quickly. The daily builds are just that - daily. A current SVN build will be newer and include all the fixes up to that point.
Comment by Richard Schofield (reszerve) - Friday, 07 May 2010, 06:21 GMT
Agree this fault is gone in the next daily build r25863-100506. Fault can be closed.

This build was not available when I lodged the fault. As I am NOT A PROGRAMMER the latest SVN was NOT an option.

I reported the fault because it was serious.

Comment by Paul Louden (Llorean) - Friday, 07 May 2010, 06:22 GMT
The latest SVN is always available. Simply download "Current build" rather than "Daily build". You don't need any programming - rbutil makes it available to me and I was using it before you filed this report.

I understand that you feel slighted, but please don't make extravagant claims like that without first actually learning about the situation.