Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iPod 5G
  • Severity Critical
  • Priority High
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Buschel - 2010-05-15
Last edited by Buschel - 2010-05-24

FS#11277 - iPod Video crashes at start up

As reported on irc the current iPod Video (32MB) builds crash at startup. A downloaded r26070 crashes with “undefined construction at 000A7F4C”, a local build based on r26060 crashed somewhere in settings_list.o

When building r26050 the iPod starts fine.

Because of my “settings_list.o”-findings I assume that r25051/52/53 is the cause of this problem.

Closed by  Buschel
2010-05-24 10:06
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in r26246.

MikeS commented on 2010-05-16 03:47

Hmmm….that update wasn't supposed to change even one instruction for anything but Gigs. Then again I found places where #includes of audio.h/audiohw.h were placed after files that now or were supposed to depend on proper setting of audio caps (like settings_list). If audiohw.h or sound.h is included too late it could change things.

MikeS commented on 2010-05-16 04:55

Try r26074 or above and see if that helps.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing