Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by mc2739 - 2010-06-03
Last edited by jdgordon - 2010-08-16

FS#11349 - Problems with %cs (Current Screen) tag

r26513

Tested and fails on e200v2 and e200v2 sim

There seems to be a problem with the %cs tag when certain screens are switched.

To reproduce the problem, I used the kleanew3 theme. This theme was disceussed in the forum: http://forums.rockbox.org/index.php?topic=24894.0 and is available here: http://www.mediafire.com/file/mzt0mqrwdhj/kleanew3.zip

I am attaching screen dumps to show correct and incorrect operation.

The steps to reproduce the problem:
1. Clear settings.
2. Set FM Region.
3. Add an FM Preset file and load it.
4. Install the kleanew3 theme. The theme requires 15-Adobe-Helvetica and 24-Terminus-Bold which are available in the font pack.
5. Switch to the kleanew3 theme.
6. Verify correct theme operation by going to the FM Radio, switching to the main menu and switching back to the radio.
7. Stop the radio (power button on e200).
8. While FM Radio is highlighted in the main menu, enter the context menu an reload the FM Preset file.
9. When the screen switches to the FM Radio, the %cs tag seems to be confused as items normally in the FM Screen are missing, and items from the menu are shown.

Stopping and restarting the radio will correct the problems.

Closed by  jdgordon
2010-08-16 13:16
Reason for closing:  Fixed
Additional comments about closing:  

r27830

Strange, the %cs tag directly uses the variable set by root_menu(). I can’t imagine rockbox functioning properly with the variable being corrupted. Maybe the skin redrawing is confused?

@JdGordon

This problem still exists with r27822

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing