Rockbox

Tasklist

FS#11360 - doom.rock fails LD linkage

Attached to Project: Rockbox
Opened by simon (kjikaqawej) - Sunday, 06 June 2010, 08:06 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 06 June 2010, 18:13 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

LD doom.rock
/usr/local/arm-elf-eabi/lib/gcc/arm-elf-eabi/4.4.4/../../../../arm-elf-eabi/bin/ld:/usr/src/other/rockbox/rockbox-svn/build/apps/plugins/doom/st_lib.o: file format not recognized; treating as linker script
/usr/local/arm-elf-eabi/lib/gcc/arm-elf-eabi/4.4.4/../../../../arm-elf-eabi/bin/ld:/usr/src/other/rockbox/rockbox-svn/build/apps/plugins/doom/st_lib.o:1: syntax error
collect2: ld returned 1 exit status
make: *** [/usr/src/other/rockbox/rockbox-svn/build/apps/plugins/doom/doom.rock] Error 1

For some odd reason it comes out as a sendmail file (according to `file').

Building using ARM GCC EABI, for a Sansa Fuzev2. The build fails as noted above. The revision is 26611 and been failing since at least 26604 or such.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 06 June 2010, 18:13 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  closing on request.
Comment by simon (kjikaqawej) - Sunday, 06 June 2010, 17:54 GMT
I'm going to try to re-build my arm toolchain, see if it's causing any issues.
Comment by simon (kjikaqawej) - Sunday, 06 June 2010, 18:09 GMT
Well, I just built 26635 and it's linking properly now. Please close this. Thank you.

Loading...