Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by perrikwp - 2010-06-07
Last edited by jdgordon - 2010-06-07

FS#11368 - Viewport Font Color WPS Tags Don't Work

While using r26651, latest SVN at the time of writing this bug report. I believe there is a bug with the skin parser or theme loader. It is not changing the font color with respect to the viewport settings.

To test this, load one theme and then load another theme’s wps file. The colors for the viewport should change depending on the colors specified in the wps file, but currently they don’t.

Another clue is that the WPS uses the same font color as the menu font color and if you try to change the menu font color in Settings→Theme Settings→Colours→Foreground Colour nothing happens.

Please correct me if I’m wrong if this is the way it is meant to work, but it worked before the skin breaking changes were recently added.

Thanks!

Closed by  jdgordon
2010-06-07 10:47
Reason for closing:  Fixed
Additional comments about closing:  

should be fixed in 26653

Another thought, it could just be that my updated theme isn’t correct. Here is the wps code just in case it is relevant: http://pastebin.com/UMKEux7Z

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing