FS#11500 - Sansa Clip theme upload fails with Unable to Load Font.

Attached to Project: Rockbox
Opened by dave t (sockbox) - Monday, 26 July 2010, 22:40 GMT
Last edited by Dominik Wenger (Domonoky) - Thursday, 29 July 2010, 22:16 GMT
Task Type Bugs
Category Theme site
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


The theme works in the sim and player but fails when uploading to the theme site. The theme validator's calculated size for the Sansa Clip themes is not consistent with the player and sim. It calculates a size much larger than the skin buffer can handle and rejects valid themes.
This task depends upon

Closed by  Dominik Wenger (Domonoky)
Thursday, 29 July 2010, 22:16 GMT
Reason for closing:  Invalid
Additional comments about closing:  Not a bug as mentioned in the comment.
Comment by dave t (sockbox) - Tuesday, 27 July 2010, 21:10 GMT
I figured it out. The theme is actually too big and does not allow room for the FMS screen to show when the FM tuner is selected. The theme will crash the sim if the FM tuner is selected, and the player will just show a blank screen. So the site is actually working properly.