• Status Closed
  • Percent Complete
  • Task Type Bugs
  • Category Codecs
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by capreolus - 2010-08-13
Last edited by saratoga - 2010-08-14

FS#11536 - m4a files won't play

m4a files show up in files list, but they don’t start to play. example file attached. Sansa Clip+; r27796-100812

Closed by  saratoga
2010-08-14 01:10
Reason for closing:  Fixed
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Fixed it in r27805.

File fails because it expect an MP4 header with type “M4A” but the file actually contains “m4a”. Changing it with a hex editor fixes it.

Technically Apple says its supposed to be lower case, but other software I’ve tried doesn’t seem to care, so I fixed it in r27805.

Edit: Flipped the cases around in the SVN commit message. Uppercase is correct, lower is less so.


Available keyboard shortcuts


Task Details

Task Editing