Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System Cowon D2
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by AsusFreak - 2010-08-18
Last edited by jdgordon - 2010-09-26

FS#11552 - Base skin: Problem with Touchscreen areas under a menu list

Hi,

I have a problem with the touchscreen areas - especially with the action ffwd and rwd.

I know it’s not documented but ffwd and rwd can be used to click through the rockbox menus.

Take a look at the following code - I saved it as buttons.sbs:

# Declaration of UI Viewport
%Vi(-,0,28,262,184,-) # Select Button on the right
%V(263,51,44,27,0)%Vf(CCCCCC)%Vb(500000)
Select
%T(0,0,44,27,select) # Up Button on the right
%V(263,93,44,27,0)%Vf(CCCCCC)%Vb(500000)
Up
%T(0,0,44,27,rwd) # Down Button on the right
%V(263,135,44,27,0)%Vf(CCCCCC)%Vb(500000)
Down
%T(0,0,44,27,ffwd) # Cancel Button on the right
%V(263,177,44,27,0)%Vf(CCCCCC)%Vb(500000)
Cancel
%T(0,0,44,27,cancel) # Up Button at the top
%V(138,0,44,27,0)%Vf(CCCCCC)%Vb(500000)
Up
%T(0,0,44,27,rwd) # Down Button at the bottom
%V(138,213,44,27,0)%Vf(CCCCCC)%Vb(500000)
Down
%T(0,0,44,27,ffwd)

If you are in absolute point mode and go to a longer menu item in the rockbox menu than you will get into trouble with the down button.

Example:
Start the fresh loaded uisimulator and switch to absolute point mode. Then load the above code as base skin and go e.g. to Plugins-Games (because there are lots of items).
Now press the Down area on the right side of the screen. Everything’s fine: one click is one step down in the menu. But now press the Down area at the bottom: one click means ~10 steps down. The amount of steps depends on the length of the list. It seems that the behaviour after clicking on the bottom Down area is mixed with the normal behaviour if you click under a longer menu list than it behaves like page down. So I think if you define an Info viewport to have a smaller menu area and then you define a touchscreen area under this info viewport the ffwd or rwd action will not work because of the forced page down function if you click under the list.

Can this be fixed or will it be unpossible to define such a touchscreen area at the bottom of a menu list and I have to do this at the sides of the list? Or must I have a bigger distance to the menu list? If I define my info viewport in the above example as %Vi(-,0,28,262,100,-) then the button works…

Closed by  jdgordon
2010-09-26 07:32
Reason for closing:  Fixed
Additional comments about closing:  

in r28168

Uups I said it’s V3.6 but I mean the current build. I did not test it on V3.6. My actual release is r27822. And I have this problem on the DAP and on the simulator.

Giova commented on 2010-08-30 14:57

I can confirm the issue on the player and the simulator for the Cowon D2 and for the ONDA VX777.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing