Rockbox

Tasklist

FS#11554 - Error compiling Rockbox Utility from SVN

Attached to Project: Rockbox
Opened by Nuno (ndias) - Thursday, 19 August 2010, 11:58 GMT
Last edited by Dominik Riebeling (bluebrother) - Thursday, 19 August 2010, 21:45 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm trying to compile the Rockbox Utility from SVN and I get this error

/usr/bin/ld: skipping incompatible rockbox/rbutil/rbutilqt/build//libmkmpioboot.a when searching for -lmkmpioboot
/usr/bin/ld: cannot find -lmkmpioboot
collect2: ld returned 1 exit status
make: *** [RockboxUtility] Error 1

It was compiling in a 32 bit system, I change to a 64 bit system and now I get this error.
I'm compiling in a Fedora 13 x86_64
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Thursday, 19 August 2010, 21:45 GMT
Reason for closing:  Not a Bug
Comment by Dominik Riebeling (bluebrother) - Thursday, 19 August 2010, 17:34 GMT
This seems like you still have a 32 bit libmkmpioboot.a around in the build folder. Please delete the build folder and start again.
Comment by Nuno (ndias) - Thursday, 19 August 2010, 21:12 GMT
Strange, I deleted libmkmpioboot.a and the error still happens, but after delete the all tree and get it again the error went away.
Thanks
Comment by Dominik Riebeling (bluebrother) - Thursday, 19 August 2010, 21:44 GMT
That's not really strange -- if you only delete libmkmpioboot.a it will get recreated from the objects that are still lying in the build folder and pretty likely built with the wrong compiler, resulting in the same issue as before.

The next time you have build issues please ask in our support channels. This is a support issue, and we don't provide any support in the tracker.

Loading...