Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface
  • Assigned To No-one
  • Operating System Sansa e200
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by seani - 2010-08-19
Last edited by mc2739 - 2010-08-21

FS#11557 - Page Flip key on vkeyboard causes corruption

This issue affects the standard 3.6 build for an E280 (fresh install via rbutil) but also affects sim and target for E280 with current trunk.

To replicate,

Settings→

Manage Settings->
  Save .cfg file

There is a single page with the default keyboard, but pressing the dedicated page-flip key (REC in this case) results in a second page with a smaller font / odd characters.

This also seems to happen where there is a custom keyboard layout with several pages.

In tests in the sim, this only seems to happen when processed via the page_flip action key; invoking page flips programatically in response to *another* key does not result in this behaviour.

Closed by  mc2739
2010-08-21 01:28
Reason for closing:  Not a Bug
Additional comments about closing:  

Closed at request of task originator

seani commented on 2010-08-21 01:21

In fact it doesn't do this at all, more failure to read properly on my part. I looked at the table of keys for the vkeyboard on the E280 in the manual and didn't look at the explanatory text that preceded it.

So I misread REC as meaning flip page, when in face REC+SELECT is flip page and REC toggles morse code input. The "corrupt" screen I was seeing was a carefully crafted explanatory screen for morse code characters.

In addition, the C240 which was my other reference point uses REC by itself as character delete so that muddied the waters a bit.

Oaf.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing