Rockbox

Tasklist

FS#1156 - noise in record when reducing input gain

Attached to Project: Rockbox
Opened by Laurent Burgbacher (burgbach) - Tuesday, 01 April 2003, 22:04 GMT
Last edited by Laurent Burgbacher (burgbach) - Monday, 15 November 2004, 08:19 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

First, thanks for this marvelous piece of good features !!!

When recording, with a recording gain of 0 on the
jukebox, if I decrease the volume of the input signal
(I use an archos mic preamp, I decrease its volume), I
get an increasing noise. If I completely plug-out the
input cable, I get a very high noise (someting like a
half of the input peak meter).

I use an archos jukebox FM recorder, 1.30j firmware,
030325-0323 rockbox.
This task depends upon

Closed by  Christi Scarborough (christi-s)
Sunday, 19 March 2006, 14:50 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Please re-open if this is still a problem
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 01 April 2003, 22:18 GMT

...and I assume that this doesn't happen when using the
Archos firmware?
Comment by Laurent Burgbacher (burgbach) - Wednesday, 02 April 2003, 06:25 GMT

you assumed correctly ;-)
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 02 April 2003, 15:40 GMT

I can't repeat it on my FM Recorder. I don't have the
external Archos mis. Can you repeat it with another analog
source?
Comment by Laurent Burgbacher (burgbach) - Wednesday, 02 April 2003, 16:21 GMT

First, I could not reproduce it, which was very frustrating for
me. Then, I turned off my jukebox, back on, and the noise
was back. Now, I can't get it working without the noise
anymore. Attached is a test file, recorded with the mic. I'm
pretty sure it's not the mic's fault, because if I plug out the
analog source audio cable, you'll ear the full noise (with HD
noises...).
The test file goes as follow : first, I say hello. The gain is max
(19.5 dB), there's some noise, but that's normal at this gain.
Then, I decrease the input volume on the mic preamp. You'll
ear the noise increase. Then, back to full volume. Finally, I
plug out the analog source cable, and you'll ear the full noise.
I'll retry tonight with other sources.
Sadly, I can't find the condition to switch from the "with-
noise" mode to the "without-noise" mode...
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 11 October 2004, 06:17 GMT

Did you ever come any closer to a solution to this?
Comment by Laurent Burgbacher (burgbach) - Monday, 11 October 2004, 07:21 GMT

no. Since this time, I did not used the "record" function
anymore. I switched back to a minidisc recorder because of
this noise.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 November 2004, 06:54 GMT

I think I know the reason to this. I feel kind of silly not
to think about this earlier. The FM radio is connected to
the Line In as well, so it may very well be the radio that
is generating all this noise.
Comment by Laurent Burgbacher (burgbach) - Monday, 15 November 2004, 07:01 GMT

So is it possible to completely turn off the radio?
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 November 2004, 07:09 GMT

I'm afraid not. As a test, you could try to tune in to a
good station before recording, just to see if the noise
turns to music.
Comment by Laurent Burgbacher (burgbach) - Monday, 15 November 2004, 07:44 GMT

Strange, because this does not always happen... It seems
like if something is not always well initialized...
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 15 November 2004, 07:57 GMT

Maybe. Perhaps there is a difference if you have the
headphones connected or not (which is the FM antenna).
Comment by Laurent Burgbacher (burgbach) - Monday, 15 November 2004, 07:59 GMT

I was not aware that the headphones were the antenna... I'll
try this.
Comment by Laurent Burgbacher (burgbach) - Monday, 15 November 2004, 08:19 GMT

I have some more information. I just tested it a little bit,
and now the situation is:
- if I go to the recording mode just after power on, I ear
the noise
- now, I go to the radio, and leave it
- back to the recording mode, no more noise.
So it seems that when I enter-leave the radio, it is well
turned off, but maybe it is not well initialized when
powering on the device.
I can reproduce this each time (tried 3 times).
I cannot find which version I use now, except that it's the
flash version. The firmware screen is blank, and the version
screen says Ver. flashedition. I hope this is sufficient...

Loading...