Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Settings
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by asettico - 2010-09-09
Last edited by mc2739 - 2010-11-17

FS#11617 - Cannot reset the original hotkey behaviour in WPS

Referred to r28030.

After to be changed the behaviour of the hotkey in WPS, it’s not possible to reset it to the original one (show folder of current track).

Closed by  mc2739
2010-11-17 13:40
Reason for closing:  Not a Bug
Additional comments about closing:  

Closed at request of originator

The default hotkey action should be “show current playlist”. What player are you refering to?

ipod video 5.5g 64 MB.
I remember that before the introduction of this feature, pressing select (the central button) I saw the content of the folder containing the current track.
The same behaviour when in WPS you press Menu and then File.

Select shouldn’t be the hotkey button. According to http://download.rockbox.org/daily/manual/rockbox-ipodvideo/rockbox-buildch4.html#x7-500004.3 it’s select+play.

In this case, it’s a real bug: the behaviour of Select and Select+Play is the same.

This is a known flaw in the way the ipod keymap is coded. I tried to fix it a few months ago in r25665, but there was significant backlash, so it was reverted in r25668. IIRC the backlash was because I committed without sufficient testing. However, the hotkey setting mechanism has changed since then and the original objections may no longer apply.

My suggestion is to change the keymap code for ACTION_TREE_HOTKEY and ACTION_WPS_HOTKEY to either BUTTON_SELECT|BUTTON_PLAY, BUTTON_SELECT or BUTTON_SELECT|BUTTON_PLAY, BUTTON_PLAY (or both) and try it out for a while to see if that works for you. If it does, suggest a commit on the IRC channel.

Ehm… I’m sorry, this is not a bug (probably this is due to a patch that interferes with the key map).
Please, close it as not a bug.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing