Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Operating System/Drivers
  • Assigned To No-one
  • Operating System iPod Nano 2G
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by RiJo - 2010-09-22
Last edited by bluebrother - 2011-06-05

FS#11638 - nano2g: shutdown hangs when keyclick is activated

When I hold down the play button to shutdown my iPod Nano 2G, I receive the shutdown message, “Shutting down…“, but nothing more happens. I think the automatic shutdown one minute later kills it, because it get stuck in the shutdown screen for about a minute.

I haven’t got this problem before, and I’m trying to update about every 2nd week or so. It occurs in the two latest builds I’ve tried:


Target: ipodnano2g
Target id: 62
Target define: -DIPOD_NANO2G
Memory: 32
CPU: arm
Manufacturer: s5l8700
Version: r28058-100909
Binary: rockbox.ipod
Binary size: 543388
Actual size: 543380
RAM usage: 1193144
Features: accessory_supply:backlight_brightness:crossfade:dircache:flash_storage:headphone_detection:hold_button:hotkey:lcd_bitmap:lcd_non-mono:lcd_color:morse_input:pitchscreen:quickscreen:rtc:swcodec:tagcache:tc_ramcache:charging:usb_charging_enable:wheel_acceleration:large_plugin_buffer:albumart:scrollwheel:usb_power:usbstack
gcc: arm-elf-eabi-gcc (GCC) 4.4.4
ld: GNU ar (GNU Binutils) 2.20.1.20100303
Host gcc: gcc (GCC) 4.4.4 20100630 (Red Hat 4.4.4-10)
Host system: Linux


Target: ipodnano2g
Target id: 62
Target define: -DIPOD_NANO2G
Memory: 32
CPU: arm
Manufacturer: s5l8700
Version: r28138-100921
Binary: rockbox.ipod
Binary size: 544184
Actual size: 544176
RAM usage: 1194072
Features: accessory_supply:backlight_brightness:crossfade:dircache:flash_storage:headphone_detection:hold_button:hotkey:lcd_bitmap:lcd_non-mono:lcd_color:morse_input:pitchscreen:quickscreen:rtc:swcodec:tagcache:tc_ramcache:charging:usb_charging_enable:wheel_acceleration:large_plugin_buffer:albumart:scrollwheel:usb_power:usbstack
gcc: arm-elf-eabi-gcc (GCC) 4.4.4
ld: GNU ar (GNU Binutils) 2.20.1.20100303
Host gcc: gcc (GCC) 4.4.4 20100630 (Red Hat 4.4.4-10)
Host system: Linux

Closed by  bluebrother
2011-06-05 10:55
Reason for closing:  Works For Me
Additional comments about closing:  

cannot reproduce, seems to be fixed.

RiJo commented on 2010-10-20 16:05

This one can be closed! It was solved by totally removing my old .rockbox directory, and then install the new one. After one reboot the problem was gone.

RiJo commented on 2010-10-20 20:17

I’ve now confirmed this bug and can reproduce it.

Steps to reproduce:
1. Make a clean installation of rockbox version r28314-101019
2. Enter Settings → General Settings → System → Keyclick → Keyclick
3. _Select_ any of Off/Weak/Moderate/Strong
4. The system wont now shutdown properly
5. After reboot the setting is restored (to null/not set) and everything works again

It shuts down normally in all other cases, such as:
* Enter Settings → General Settings → System → Keyclick → Keyclick, and return back without changes
* Enter Settings → General Settings → System → Keyclick → Keyclick, and hold down play button to shut down
* Change value of Settings → General Settings → System → Keyclick → Keyclick

I have ipod nano 2g too and happens exactly the same thing, the solution was to disable key click.

Version: r28323-101021

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing