Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category User Interface → Themes
  • Assigned To No-one
  • Operating System Cowon D2
  • Severity Low
  • Priority Very Low
  • Reported Version Daily build (which?)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by AsusFreak - 2010-09-28
Last edited by jdgordon - 2010-10-12

FS#11645 - Album Art and conditional with timing

Hi.

I got a problem with the timing of the album art drawing.
In past builds the attached code leads to a static album art in the background and alternating showing of the bitmap(button) and the text line.
It did behave like this:
1. Album Art is drawn
2. text line is shown as overlay, because touchscreen is not pressed.
3. If touchscreen is pressed the textline disappears and the bitmap (button) is shown for 2 seconds.
4. After 2 seconds the button disappears and the textline is shown again.
In the past you did not see any black squares at the place where an item disappeared - the album art seemed to be redrawn after the timer got to zero.
My last working build was r27530.

Now with an actual build (r28177) it seems to be that the album art isn’t drawn so often. As a result the black squares stay on the screen. This leads to ugly effects with my AF_Black theme:
http://themes.rockbox.org/index.php?themeid=1019&target=cowond2

I tried to place more %Cd lines in the code just to force a redrawing of the album art but this did not work, too.

The simplified code for testing purposes is here:

# disable the status bar
%wd

# preloads album art 240×240 %Cl(0,0,240,240)

# preload images
%X(bg.bmp)
%xl(a,voldown.bmp,0,0)

# Show Album Art
%V(40,0,240,240,0)
%Cd

# Touchscreen pressed ?
# Yes → Viewport p
# No → Viewport n
%V(0,0,0,0,0)
%?Tl(2)<%Vd(p)|%Vd(n)>

# Yes → Show Onscreen Buttons
%Vl(p,138,105,40,29,0)
%T(0,0,40,29,voldown)
%xd(a)

# No → Show text as overlay
%Vl(n,43,204,234,13,1)
%ac%ia

Closed by  jdgordon
2010-10-12 10:16
Reason for closing:  Not a Bug
Additional comments about closing:  

see comment

does this still happen?

not a bug.

Your AA is in a conditional viewport which gets cleared when a button is pressed (you disable the k viewport), to fix this you just need to make sure the k viewport is redrawn every time the touch changes (so on or off)… i.e simple fix is add %Vd(k) in line 141.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing