FS#1165 - Misbehavior in "Set Time/Date" screen (NOT a settings loss)

Attached to Project: Rockbox
Opened by J. A. Swami (jaswa) - Friday, 04 April 2003, 05:03 GMT
Last edited by Daniel Stenberg (bagder) - Tuesday, 03 June 2003, 14:39 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


It's expected that when you replace your batteries you'll
lose your time/date settings.

Here's what's not expected:

1. Remove and replace your batteries.

2. Go to "Set Time/Date."

3. You'll see something like this:

Set Time/Date


Sat 20165 09

ON To Set

OFF To Revert

Note the wrong format for the "Date" line.

The proper format, of course, would be something like

Wed 2016 Mar 09

If you place your cursor on "20165" and then press the
right arrow, the cursor will disappear. And if you then press
the up or down arrow, the name of a month will appear.
You can then set the proper date. When you press "ON To
Set," the system then behaves normally.

Whenever you replace batteries, this behavior consistently
recurs. (Or at least it does for me.)

Archos 0S: 1.28

Hardware: Recorder 20: JBR20101

Version: CVS-030403


J. Swami

This task depends upon

Closed by  Daniel Stenberg (bagder)
Tuesday, 03 June 2003, 14:39 GMT
Reason for closing:  Fixed
Comment by Markus Braun (malle) - Tuesday, 27 May 2003, 14:30 GMT

This should be fixed in cvs.