Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bugs
  • Category Plugins
  • Assigned To No-one
  • Operating System Another
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by seier - 2010-10-09
Last edited by speachy - 2024-04-21

FS#11661 - Messages and Heads up display fonts are unreadable in doom

While playing doom, I can definitely read the amount of ammo, shield status, and health of my character. However, I cannot read the messages like you need the key first to open this door. Also, if you set the screen size to the maximum and turn on the heads up display the font there is also illegible.

Closed by  speachy
2024-04-21 01:03
Reason for closing:  Out of Date
Additional comments about closing:   Warning: Undefined array key "typography" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 371 Warning: Undefined array key "camelcase" in /home/rockbox/flyspray/plugins/dokuwiki/inc/parserutils.php on line 407

Probably not something we can fix anyway due to tiny screen resolutions.

nls commented on 2010-10-09 08:25

Which player, revision of rockbox and doom wads are you using?

seier commented on 2010-10-09 11:23

Hi Nils, I'm using the default 3.6 stuff with my Sansa Fuze v2.

nls commented on 2010-10-09 11:55

Could you please try this with a current build then?

seier commented on 2010-10-09 16:42

I'm sorry, I'm using the newest stable build, r28188-100930. Did you want me to try a beta? Please send me a link to the one you want me to use, because I don't know where to even download the betas.

Obviously, the problem is that the screen is being scaled to your device. The fonts need to *not* be scaled as much, and/or the fonts in the engine need to be increased in relative size. So the stretching routine should de-stretch just the fonts. Dithering some, better or more might help, but that is not the big problem. One could also add some code to switch the screen to a text reading plugin, and switch back or something, but that is bit much. The truth is that these messages are usually unneeded, since the color of the door indicates the color of the key you need to find, and this is the only message besides plot ones, which are the real problem.

I wonder if this was already fixed in prboom+.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing