Rockbox

  • Status Closed
  • Percent Complete
    100%
  • Task Type Patches
  • Category Codecs
  • Assigned To No-one
  • Operating System All players
  • Severity Low
  • Priority Very Low
  • Reported Version Release 3.6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Rockbox
Opened by Andree Buschmann - 2010-11-03
Last edited by Andree Buschmann - 2010-11-07

FS#11716 - mpa: move dct32 to IRAM

Speed-up on S5L870x (nano 2g) is ~4-5%. No impact on PP502x / PP5002.

Should be measured on other CPUs as well.

Closed by  Andree Buschmann
2010-11-07 22:31
Reason for closing:  Invalid
Andree Buschmann commented on 2010-11-04 20:34

Tested with mp3 local testfile, 220 kbps.

nano 2g (S5L8701): svn 56.2 MHz, v01 53.7 MHz

Andree Buschmann commented on 2010-11-07 09:41

Minor refacturing of the iram-defines. During refacturing I came by the fact that ICODE was used for Coldfire CPUs MCF5250 and MCF5249. Normally those CPUs suffer from moving code to IRAM, therefor the v02-patch do not use ICODE for those both CPUs anymore. Patch needs to be benchmarked on those CPUs.

Andree Buschmann commented on 2010-11-07 11:53

v02 tests by n1s:
h300 (mcf5249): svn = 26.50MHz, patch = 26.47MHz for a 128k sample
fuzev1 (AS3525): patch 1 MHz slower than svn

Andree Buschmann commented on 2010-11-07 13:24

Sorry to say, but the speed-up on S5L seems to be a mis-measurement by myself. I cannot reproduce the result…

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing